Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to remove libavcodec52 package but it won't work. If I try through Software Central it just tells me it didn't work and to check my internet conection.

If I try it at the terminal, this is what I get

Souljacker Ahab @: ~ $ sudo apt-get remove libavcodec52
Reading package lists ... ready
Building dependency tree
Reading state information ... ready
The following packages were automatically installed and are no longer needed:
   libmodplug1 libtwolame0 libva-1-x11-libxcb libxcb-keysyms1 xv0 libcddb2 libass4 libdvbpsi6 libvlc5 libupnp3 libxcb-7-randr0 libiso9660 libkate1 vlc-data
   libtar libvlccore4 libvcdinfo0 libebml3 libmpcdec6 libmatroska3 libsdl-image1.2 liba52-0.7.4
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
   libavcodec libavformat-extra-extra-52-52 libopenjpeg2 librtmp0
Suggested packages:
The following packages will be REMOVED:
   libavcodec52 libavformat52 vlc vlc vlc-nox vlc-plugin-notify-plugin-pulse
The following NEW packages will be installed:
   libavcodec libavformat-extra-extra-52-52 libopenjpeg2 librtmp0
0 upgraded, 4 newly installed, 6 to remove and 1 not upgraded.
You must download kB/5.489 127 kB file.
After this operation, 12.1MB disk space will be freed.
Do you want to continue [Y / n]? s
Err Natty / universe libopenjpeg2 i386 1.3 + dfsg-4
   404 Not Found
Err Natty / universe librtmp0 i386 2.3-2
   404 Not Found
Http:// Failed to fetch 404 Not Found
Http:// Failed to fetch 404 Not Found
E: Unable to fetch some archives, maybe run apt-get update or try with - fix-missing?

I've tried an apt-get update and nothing changes.

Any help?

share|improve this question
LANG=C apt-get ... will print the message in the default language (English, technically C is for POSIX). This makes it easier to discuss the problem in an international forum. – Jan Aug 19 '11 at 19:00
Your terminal output is not in English, which might make it difficult for lots of people to answer your question. You should consider temporarily changing languages and reposting the output. Or at least translating the error messages. – Kris Harper Aug 19 '11 at 19:01
@Souljacker Welcome! i have added the google translation if you think that is the correct translation you may remove the Portuguese ;) – Achu Aug 19 '11 at 19:04
I was just thinking about the language issue, so I swiched Ubuntu to English and also changed it's default repository to the original instead of the one in Brazil. And that was it. Now removal is working ;) I've seem plenty of Brazilian people with the very same problem while searching for a solution. Maybe this will help then :) – Souljacker Aug 19 '11 at 19:16… Try updating your server and then try the command again – Allan Aug 19 '11 at 19:31

I did a little searching and it seems the problem is with the Brazilian repository
mirror ( Go to Software Center ➜ Edit ➜ Software Sources... and change the download server.

share|improve this answer
AS i'VE SAID UP THERE, THERE WAS IT. tHANKS A LOT :) – Souljacker Aug 19 '11 at 21:55

Edit: apt is also part of the problem, but DoR is right, the main problem is with connection to Brazilian mirror, so change of mirror will solve this problem as well.

There are some packages depending on libavcodec52 (in my system I've found mplayer, but also vlc and maybe other multimedia applications) and it seems apt can't resolve this conflict.

You can try to remove those applications first (I see VLC in the apt output) and then remove libavcodecs52 or install aptitude which has better system for resolving conflicts.

aptitude has similar syntax, so you can remove packages using

sudo aptitude remove package

Tried and worked for me - apt is "stuck" but aptitude offers removing of mplayer and that solves the problem (libavcodecs52 is removed properly without installing anything new).

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.