Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have two monitors. The left monitor is set as primary, but the Unity Launcher appears on the right monitor.

dual screen issue

How can I move it to the other monitor?

share|improve this question
    
Needed to solve that me too xD PS : Where did you found this wallpaper ? –  aliasbody Jul 16 '12 at 2:22

5 Answers 5

up vote 12 down vote accepted

This is a bug:

(taken from the bug report)

Permanent workaround (requires logging back in again):

Edit ~/.config/monitors.xml, find the monitor you want the launcher to display on and change:

<primary>no</primary>

to:

<primary>yes</primary>

Now log out and log in again.

Temporary workaround (no logout required):

Open a Terminal window and...

  1. Run xrandr to find the NAME of the output you would like to make primary.
  2. Run xrandr --output NAME --primary && nohup unity --replace &
share|improve this answer
2  
The workaround listed there fixed this. Thanks! –  James Aug 19 '11 at 18:20
    
paste.ubuntu.com/844605 that is my monitors.xml file.. I have also attempted to run the listed command sudo xrandr --output DVI-I-2 --primary && nohup unity --replace & and the launcher still remains on my left (smaller) non primary monitor. –  rlemon Feb 16 '12 at 16:42
1  
nevermind.. Just read the top of the page that there is no workaround for 11.10 but there is a ppa... gonna try that now. –  rlemon Feb 16 '12 at 16:43
    
brillaint. thanks –  tomwrong Oct 16 '13 at 10:00

It isn't configurable in 11.04, but it is a known issue and I think I've read that it's fixed in 11.10. Not sure though.

share|improve this answer

A couple things to try. You can follow the instructions here.

In summary, run xrandr to get a list of your monitors. The first one listed (e.g. VGA1) will be your primary monitor. Then run sudo xrandr --output VGA2 --primary to make your second monitor primary. Note that your monitors may not be called VGA1 and VGA2. You'll need to look at the xrandr output to find the correct names.

Secondly, your monitors look like they might have the same connection type. If that's the case, you could try switching the cables they use to connect.

Lastly, if all else fails, you could just switch the physical location of the monitors. Maybe not the best solution, but also probably the simplest.

share|improve this answer
    
Thanks. I ran the following command and it worked like a charm in ubuntu 11.04! sudo xrandr --output VGA1 --primary # VGA1 was my samsung bigger monitor –  user24836 Sep 12 '11 at 4:38

for 11.10 there is no workaround, but there is a ppa on launchpad (unsupported) that fixes the issue.

To install:

  1. sudo add-apt-repository ppa:vanvugt/unity
  2. sudo apt-get update
  3. sudo apt-get install unity

You will need to relog for the changes to take effect.

share|improve this answer

If you are using Ubuntu 13.10 and up

On the same window where you set your screen orientation (System Settings>Displays:Launcher Placement) you can set the screen(s) on which the launcher show show up:

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.