Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My monitor brightness is reduced because it was causing me headaches. Web pages are displayed fine, but flash videos are too dark. I can control gecko-mediaplayer plugin brightness via mplayer config, but I'm not able to do the same for flash.

In Windows I was able to do that via nvidia driver settings, which allows to control video overlay brightness independently, but the Linux nvidia driver doesn't allow to do that.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

You can control video overlay settings with the proprietary NVIDIA driver. (nvidia-current package, in case you're using the default nouveau driver.) Open System > Administration > NVIDIA X Server Settings. Hit X Server XVideo Settings in the list on the left, and tweak the values on the right to suit your needs. This should affect anything that uses XVideo, such as most media players.

The only issue may be Flash, which could bring you back to square one. It's possible that it does use XVideo (and awesome if it does) but if not you don't have a whole lot of options for that.

Edit: I tried this out myself, and it turns out Flash is not affected, unfortunately. You may have to wait for Adobe to implement XVideo or video acceleration in Flash unless another solution comes up.

However, it is possible that the darkness issues you're experiencing could also be video driver related, though I've never heard of an instance of this on Linux before.

NVIDIA XVideo settings screenshot

share|improve this answer
    
Thanks for your answer. Very helpful. Unfortunately, there are two problems. First, flash indeed doesn't use xv. The second one is that I don't have those options in my nvidia "X Server XVideo Settings". The only option I have is "Sync to VBlank" for "Video Texture Adaptor" and "Video Blitter Adpator Settings". Perhaps my card, which is a 7300GT doesn't support it. –  lovinglinux Oct 10 '10 at 22:38
    
Interesting. You're probably right; it may not be supported there. This screenshot is from the 260 driver. –  Jacob Peddicord Oct 10 '10 at 23:36
    
I'm also using the 260 driver. –  lovinglinux Oct 11 '10 at 0:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.