Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

There are similar issues to this raised before, and in general many about multiple monitors since Unity, but not this precise one, and no complete answers. I have a couple of Dell Precision laptops (most recently M4600 - with nvidia quadro 2000M gpu), which have Fn+F8 as the dynamic display switch (loops round laptop -> laptop+external -> external only, like most laptops). Until Ubuntu 11.04 this worked fine (for several years) but since 11.04 its been broken. Just doesn't work. I've tried to find solutions, hacks, etc, have posted on official ubuntu forums, but it's just broken. I travel a lot and give a lot of (scientific) presentations, and really need this functionality. Since 11.04 I have to stand up at a conference, plug in my laptop and then go through the hassle of nvidia-settings, detect displays, mirror displays, apply, etc. Argh. Its the biggest issue I've had with Ubuntu in years. I've taken to giving other people PDF files to show on their laptops, which excludes me from showing animations of data, etc. Here's hoping I'm being daft and someone can help me out. Note that the projectors used are all different in different places, so they have to be dynamically detected each time (but, then again, 10.10 and all previous Ubuntus did this fine.).

share|improve this question
    
possible duplicate of Fn+F2 LCD/CRT display toggle stopped working in 11.04 –  James Henstridge Aug 19 '11 at 7:57
    
Not a duplicate, the other question is about toggling backlight where this one is about switching displays. Sounds like a kernel problem to me. –  Lekensteyn Aug 19 '11 at 8:17
    
This should be a bug report. The interesting question is to discover what is the issue here (kernel, nvidia drivers). –  Javier Rivera Aug 19 '11 at 8:35
    
The other question had nothing to do with backlights. It was about the video output switch, the same as this one, and probably has the same cause: the BIOS rewrites the key sequence to Win+P, and Unity captures that key sequence and ignores it. –  James Henstridge Aug 19 '11 at 9:01
    
Rob: if the display switch key works for you with the "Ubuntu Classic" session option from the login screen but not standard "Ubuntu" one, then my answer on the other question accurately describes your problem. Until the bug in Unity is fixed, the problem will persist. The bug wasn't present in earlier Ubuntu releases because they didn't ship Unity. –  James Henstridge Aug 21 '11 at 0:24

1 Answer 1

You could try the Disper utility and the Disper-indicator. It won't (yet?) work with the keyboard shortcuts. Instead it gives you an indicator icon from which you can choose the desired monitor setup.

The Disper utility works with both the XRandr backend and the proprietary NVidia driver (though I have only tried it with the nvidia driver).

Check it out:

Disper ppa: https://launchpad.net/~disper-dev/+archive/ppa

Disper-indicator ppa: https://launchpad.net/~nmellegard/+archive/disper-indicator-ppa

All the best N

share|improve this answer
    
Hi - many thanks for the quick answer. I should have said that I tried disper and it works sometimes but is not reliable enough to use in short time in front of an audience. The crazily frustrating thing is that the regular keyboard combo WORKED for the past 2+ yr under ubuntu and now they've broken it. Anyone else got any ideas ? thanks. Rob. –  Rob Fender Aug 19 '11 at 10:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.