Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm new to Linux. I installed Ubuntu 11.04 on a partition and I love it, but Ubuntu One does not work. I created a free account and a directory Ubuntu One appeared automatically, as expected. I copied there some files and a couple of directories, just text files, therefore very light. U1 tries to sync, but fails and keeps on trying again. When I close the session I must force exit, because it is still trying. My router has a firewall: can it cause the failure? When I use Windows, on the other partiton, I have no problem with Dropbox.

share|improve this question
add comment

4 Answers

Solved. See Does Ubuntu One require administrator privileges?

Hi, Looks like you have switched users. If you log in to Ubuntu One and sync your >files, then log into Ubuntu One as a different user on your ocmputer and perform a >sync without clearing out the old metadata you will get errors. To fix this please >open a Terminal and run the following commands:

u1sdtool -q

rm -rf ~/.local/share/ubuntuone

u1sdtool -c

Let Ubuntu One run for a bit as it recreates your metadata.

share|improve this answer
add comment

Looks like it's using SSL. I launched Ubuntu One on my system and then ran tcpdump and egrepped on 'Ubuntu' and attached a screenshot of the output. It may be possible your firewall does not support SPI to remember the SSL state as Ubuntu One is making connections back to your machine over a different port. I would just add an exception rule for *.canonical.com and see if that works.

tcpdump output of Ubuntu One Connection

share|improve this answer
    
Thank you for your answer. Unfortunately I'm not skilled enough, so I have some more questions: –  alberto bicego Aug 20 '11 at 10:18
    
Sorry, firefox suddenly closed while I was adding a comment (it does so, from time to time, and I have no idea why). Here are the questions I wanted to pose: 1. Is Ubuntu One supposed to use SSL? In this case should I not install a digital certificate? How can I find it? 2. How can I know if my firewall supports SPI (I don't know what it is)? 3. Last, but most important: how can I add an exception rule? My router is a Siemens; I looked at the configuration, but I could not find anything like "exception rules" Thank you for your patience. –  alberto bicego Aug 20 '11 at 11:10
add comment

It might also be the current lack of proxy support in the Ubuntu One client which could be causing you a problem, if you use a proxy to connect to the Internet that .

The developers are aware of this short coming , and have promised a fix shortly.

It would also explain why Dropbox is working, as it works perfectly through a proxy, when configured correctly.

share|improve this answer
    
Thank you for your answer, but I don't use any proxy. –  alberto bicego Aug 24 '11 at 17:54
add comment

I would suspect a DNS lookup fault. Simply change your DNS to Google's public DNS or OpenDNS. Both are free.

To answer your questions in the comment:
1) Yes, it is supposed to. No, you don't have to install anything. (There is a set of certificates your system 'knows' by default. Like you could identify 5 currencies. Let's say these are the biggest and most trusted, most used ones. So you are all fine. In case you would REALLY need an another currency (a new certificate), you have to install it. BUT, Ubuntu got a package for this, and the Canonical team updates that package every time you need a new certificate, or remove an old one. Just don't forget to update your system once in a while.)

2) Usually your router uses an SPI firewall. But that won't block such service, so I guess you can rule that one out ... too. (But in case, just go to your router's web interface, and disable the firewall.)

3) You don't have to. Read point 2.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.