Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Yesterday I finally got around to upgrading from 10.04 to 11.04 (I'm very forgetful about such things). I did an upgrade through the update manager, first to 10.10, then to 11.04. Unfortunately, I've run into an issue, stemming primarily (I believe) from the fact that my hardware doesn't seem to support Unity.

When I boot my machine, I get a screen that looks like this one (linked because the original image is kinda large). It stays on this screen indefinitely, with no animation, no mouse movement, no dialogs, etc.

However, I am still perfectly able to connect to the machine via SSH, and even create NoMachine connections with a Gnome session running on the computer. So it isn't freezing, it just no longer presents a working GUI frontend on the primary monitor. Needless to say, this is inconvenient. So I'm going to purchase a Unity-approved graphics card for the beast, but I'm wondering if there's anything I can do in the meantime, to get a Gnome or Xfce session going when I'm at the physical machine. Thanks to SSH it would be very easy for me to manipulate config files.

EDIT: Information about my graphics card:

$ lspci -v | grep VGA
  00:10.0 VGA compatible controller: nVidia Corporation C73 [GeForce 7050 
  / nForce 610i] (rev a2) (prog-if 00 [VGA controller])
share|improve this question
can you clarify the upgrade procedure - was it a new install of 11.04, or did you upgrade 10.04 --> 10.10 --> 11.04. Please also add details of your graphics card to your question. – fossfreedom Aug 18 '11 at 14:12
@fossfreedom Main post edited to reflect your suggestions – asfallows Aug 18 '11 at 14:18
I'm fast coming to the conclusion that 11.04 is the WindowsME of the Linux world. Hopefully 11.10 will sort it all out. As it stands, I'm now running Xubuntu on most of my systems since the chances of Unity and I co-existing peacefully is somewhere between zero and none :-) – paxdiablo Aug 19 '11 at 3:14
up vote 2 down vote accepted

A couple suggestions to try:

  1. xorg.conf - possibly you had installed a nvidia driver, but through the upgrade it has been replaced by the open-source variant. Try via SSH sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.backup
  2. KMS issue - possibly you have to boot with nomodeset in your grub boot option. Whilst booting press shift to display your grub. Press e to edit the grub line. Then add nomodeset immediately before quiet splash. CTRL + X to boot.
share|improve this answer
Your first suggestion worked, although I was helped in getting it to work because of @Geppettvs 's suggestion to kill splash from the grub.cfg lines. I was able to see where the boot process was halting, get to a bash shell with Alt+F4, and make the edits that way. After I moved xorg.conf, startx worked right away. Thanks! – asfallows Aug 19 '11 at 2:46

The Troubleshooting Blank Screen at Ubuntu Wiki provides enough information about how to manage these issues, which I can't say what would fit your needs but take a look at that document in order to get a clue on where to start.

Quoted from the site:

If you see a screen of a different color (brown, white, multi-colored corruption, etc.) you are seeing a different class of graphics bug. Obtaining register dumps (see below) may still be of value however.

In my case what solved my problem was to edit the GRUB List at /boot/grub/grub.cfg and remove the "splash" parameter of each GRUB's entry, which may be different in your case as mentioned in the Wiki page:

To check this, in the grub menu edit the kernel line and remove 'splash' from the end of the line, and boot. If that solves the issue, you can remove it from your /boot/grub/menu.lst as a workaround.

NOTE: even when this document refers to the menu.lst file, that file doesn't exist inside my /boot/grub folder, which is grub.cfg in my case. (I can't say why but no need to comment about it)

Also Check the Analysis techniques section of the page in order to gather further information related to your specific issue and let us know, somebody may have more experience with your specific problem than I do.

Keep us posted on your issue.

Good luck.

P.S. You can edit your /boot/grub/grub.cfg using a live session CD/DVD but make sure you always keep a backup of your original file.

share|improve this answer
+1 because your suggestion helped me get to the solution, but I accepted the other answer because it got me all the way. :) – asfallows Aug 19 '11 at 2:47

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.