Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I would like to install the latest version of the Broadcom wireless driver (hybrid-portsrc_x86_64-v5_100_82_38). I'm using Ubuntu 10.04 (Linux kernel: 2.6.32-33-generic). According to the lspci command, my network controller is "Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN".

I found the Linux driver of BCM4311 at http://www.broadcom.com/support/802.11/linux_sta.php. Then, I followed the instructions at http://www.broadcom.com/docs/linux_sta/README.txt to install http://www.broadcom.com/docs/linux_sta/hybrid-portsrc_x86_64-v5_100_82_38.tar.gz. Specifically, I removed all of the existing wl, ssb and b43 modules. Then, I built the module and loaded it. All of the depmod, modprobe and insmod finish without reporting any problems. And, the lsmod command shows my new wl module. But, my network manager doesn't show any wireless connections.

The following is the output of the lspci -n | grep 14e4 command on my machine:

09:00.0 0200: 14e4:1673 (rev 02)
0c:00.0 0280: 14e4:4311 (rev 01)

The following is the output of sudo lshw -C network:

*-network UNCLAIMED     
    description: Network controller
    product: BCM4311 802.11b/g WLAN
    vendor: Broadcom Corporation
    physical id: 0
    bus info: pci@0000:0c:00.0
    version: 01
    width: 32 bits
    clock: 33MHz
    capabilities: pm msi pciexpress bus_master cap_list
    configuration: latency=0
    resources: memory:f6cfc000-f6cfffff

How can I troubleshoot my problem with the latest version of the Broadcom driver?

share|improve this question
    
This question appears to be abandoned and unanswered. If this question no longer applies then you can either delete it or answer it yourself if you've solved the problem. Thanks! –  nitstorm Feb 24 '12 at 17:58
    
I finally resolved the problem by installing a newer version of Ubuntu from scratch. –  reprogrammer Feb 26 '12 at 22:59
add comment

closed as too localized by nitstorm, jrg Feb 24 '12 at 19:43

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

A few things to check, in order:

Does the wireless network device appear?

Check that your wireless adapter appears in the output of ip link. This will print a couple of lines about each of your network interfaces. Check for a wlan0 entry, or something similar.

If your wireless device does not appear, it would indicate that the driver did not recognise your device. Check the dmesg output to see if there's any relevant kernel logs.

Does it look like a proper wireless device?

Run iwconfig; it will probably state that most of your network interfaces have "no wireless extensions", but it should print some wireless-related info (mode/essid/wireless standards supported) for at least one device.

If your wireless device is present but does not list any wireless extentions, this would indicate a problem with the driver. Look for interesing info in dmesg.

If iwconfig prints an error, this could indicate a compatibility problem with the new driver and the userspace tools.

Is Network Manager recognising your wireless device?

Run nm-tool, and make sure that your wireless device is present in the output, and that it has some 'Wireless Properties' listed.

If not, this could indicate an interaction problem between the new driver and the Network Manager build. Check /var/log/syslog for NetworkManager-related entries.

share|improve this answer
    
The output of ip link contains information about lo and eth0 not wlan0. The output of dmesg | wl is the following: [ 27.593069] wl: module license 'unspecified' taints kernel., [ 27.600936] wl 0000:0c:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17, [ 27.600945] wl 0000:0c:00.0: setting latency timer to 64 I didn't find any useful infromation in the output of dmesg. Do you have any other suggestions on how to proceed? –  reprogrammer Aug 20 '11 at 10:15
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.