Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I noticed just about all the file system modules are loaded by default on boot - filesystems I'll never use. These include atleast:

Module                  Size  Used by
jfs                   182186  0 
xfs                   823190  0 
reiserfs              248223  0 
btrfs                 550402  0 
ufs                    75815  0 
qnx4                   17685  0 
hfsplus                84797  0 
minix                  36367  0 
ntfs                  101769  0 

Is there anything I can do to prevent these being loaded ?

share|improve this question

2 Answers 2

up vote 3 down vote accepted

You can blacklist them in /etc/modprobe.d/blacklist.conf by adding blacklist xfs blacklist reiserfs etc. You can also create your own blacklist there. for example blacklist-mine.conf.

Still it's strange that all those are loaded. Have you started gparted before checking or are you on a live system maybe?

share|improve this answer
1  
That seems to do the trick, although sudo /sbin/update-initramfs -u needs to be run as well, after altering blacklist.conf –  nos Aug 17 '11 at 21:31

One reason for these filesystem modules being loaded is down to a package called os-prober which is used by grub-common to detect other OSes on attached disks (specifically in /usr/lib/os-probes/init/10filesystems). This gets called by grub2 related packages and other system updates.

However the filesystem check (and the subsequent loading of the modules) can be disabled on a system by adding the following line to the grub config file /etc/default/grub:

GRUB_DISABLE_OS_PROBER=true

Then one needs to run the update-grub command to update /boot/grub/grub.cfg:

sudo update-grub
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.