Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This is a problem that started very recently: every time I turn my computer on, Ubuntu boots into a classic GNOME desktop session instead of Unity, which is set to the default login option. Also, the GNOME desktop loads a resolution of 1024x768 instead of 1280x1024, which is my default resolution. There is no option to put the resolution back in 1280x1024. Logging out and back in doesn't fix the problem. Only opening a terminal and typing unity --reset seems to correct this. Afterwards, Unity works in the right resolution without any problems.

I'm using nVidia 8500GT and the current proprietary dirver installed through the "additional drivers" program.

Anyone has any idea what might be causing this?


I'm using nVidia 8500GT and the current proprietary dirver installed through the "additional drivers" program. I am the one who asked the question, by the way, I just made an account right now.

share|improve this question
    
this might be a video driver issue, what video card and driver combo are you using? –  Dirk Hartzer Waldeck Aug 17 '11 at 7:14

1 Answer 1

up vote 1 down vote accepted

the resolution issue can be fixed by setting the resolution with the nvidia-settings manager, setting the resolution and not just apply it but save the configuration "Save to X configuration file", if I'm not mistaken this will fix unity as well.

If you get the error after rebooting (just after logging in) that your default settings aren't correct you can repeat the above but unmark the field merge settings when saving to x config.

share|improve this answer
    
Okay, I'll try that, thank you very much. :) –  Zorbama Aug 20 '11 at 19:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.