Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Trying to compile Awesome Window Manager on 11.04, I've done apt-get build-dep awesome but still get errors about missing dependencies:

$ make
Running cmake…
-- cat -> /bin/cat
-- ln -> /bin/ln
-- grep -> /bin/grep
-- git -> /usr/bin/git
-- hostname -> /bin/hostname
-- asciidoc -> /usr/bin/asciidoc
-- xmlto -> /usr/bin/xmlto
-- gzip -> /bin/gzip
-- lua -> /usr/bin/lua
-- luadoc -> /usr/bin/luadoc
-- convert -> /usr/bin/convert
-- checking for modules 'glib-2.0;cairo;x11;oocairo;oopango;xcb-randr;xcb-xtest;xcb-xinerama;xcb-util>=0.3.8;xcb-keysyms>=0.3.4;xcb-icccm>=0.3.8;xcb-image>=0.3.0;cairo-xcb;libstartup-notification-1.0>=0.10;xproto>=7.0.15;libxdg-basedir>=1.0.0'
--   package 'oocairo' not found
--   package 'oopango' not found
--   package 'xcb-util>=0.3.8' not found
--   package 'xcb-icccm>=0.3.8' not found
CMake Error at /usr/share/cmake-2.8/Modules/FindPkgConfig.cmake:266 (message):
  A required package was not found

I don't see any sign of these libraries in the repos.

I tried the instructions at and that also fails:

$ cd util && ./ && make && sudo make install
autoreconf: Entering directory `.'
autoreconf: not using Gettext
autoreconf: running: aclocal -I m4
autoreconf: tracing
autoreconf: not using Libtool
autoreconf: running: /usr/bin/autoconf
autoreconf: not using Autoheader
autoreconf: running: automake --add-missing --copy --no-force installing `./install-sh' installing `./missing'
src/ Libtool library used but `LIBTOOL' is undefined
src/   The usual way to define `LIBTOOL' is to add `AC_PROG_LIBTOOL'
src/   to `' and run `aclocal' and `autoconf' again.
src/   If `AC_PROG_LIBTOOL' is in `', make sure
src/   its definition is in aclocal's search path.
src/ installing `./depcomp'
src/ `xcbinclude_HEADERS' is used but `xcbincludedir' is undefined `pkgconfig_DATA' is used but `pkgconfigdir' is undefined
autoreconf: automake failed with exit status: 1

What do I need to do to be able to compile?

share|improve this question
Why do you need to compile awesome? It is available in the repos. And by the way build-dep is for compiling a package obtained with apt-get source <package>. – enzotib Aug 17 '11 at 7:30

2 Answers 2

Looks like you need to install libxcb-icccm1-dev package.

share|improve this answer

You're not required to compile, anyways like @enzotib said, youre only supposed to do that for

apt-get source <package>

Just use

sudo aptitude install awesome
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.