Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I salvaged good old T60 machine, with ATI X1400 and hi resolution screen (1600x1200). My problem is that Ubuntu does not detect higher resolutions than 1024x768. I can that radeon driver is sed (xserver-xorg-video-radeon). When I install fglrx drivers, the systems seems not to see 3d acceleration at all, legacy gnome starts and still can't change the resolution.

Additionally xrandr shows, look at maximum ... it is something wrong.

tdi@congruence:~$ xrandr
Screen 0: minimum 320 x 200, current 1024 x 768, maximum 8192 x 8192
VGA-0 disconnected (normal left inverted right x axis y axis)
LVDS connected 1024x768+0+0 (normal left inverted right x axis y axis) 285mm x 214mm
1024x768 60.0*+
800x600 59.9
848x480 59.7
720x480 59.7
640x480 59.4
DVI-0 disconnected (normal left inverted right x axis y axis)

Has anybody encountered such a problem before? Probably ATI X1400 issue, not thinkpad.

share|improve this question
    
Did you try to install the proprietary ATI driver with the additional drivers program? –  queueoverflow Aug 16 '11 at 22:19
    
@queueoverflow yes I did, but fglrx from repositories does not suport my card, and the one from ATI site is too old for the xorg ubuntu uses. –  tdi Aug 17 '11 at 6:27
    
that figures for ATI … the X1400 is a kinda old card, so I would have expected for it to work OOTB. So the free driver is what you have installed now? I would now edit the xorg.conf and enter the native resolution there. Then it might be available. –  queueoverflow Aug 17 '11 at 12:05

1 Answer 1

up vote 2 down vote accepted

(using the steps from here : http://osarena.net/2011/08/pos-na-prosthesete-tin-katallili-analisi-stin-othoni-sas-an-den-anagnorizete-aftomata.html )

  1. According to your output your connected screen is the LVDS connected (we will need that.)

  2. Next you must find your screens modelines which can be obtained through:

    • your manual,

    • the constructors (of your screen) site or

    • this site

  3. Open a terminal and run

    xrandr –newmode “ModeName” <modeline>
    

    where ModeName is just a name of your choice and <modeline> the one from the previous step.

    example :

    xrandr –newmode "1920x1080_60.00″ 148.35 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync
    
  4. Then run this to add the new configuration:

    xrandr –addmode <your connection name> <your modeline's name>
    

    Your connection name is the one from the step 1.

    example :

    xrandr –addmode VGA-0 1920x1080_60.00
    

    where:

    • ModeName = 1920x1080_60.00
    • connection name = VGA-0
  5. Then run gksu gedit /etc/gdm/PreSession/Default and add the 2 previous lines to the end of the above file.

    example:

    xrandr –newmode «1920x1080_60.00″ 148.35 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync
    xrandr –addmode VGA-0 1920x1080_60.00
    
  6. Through your monitor settings, choose your new resolution.

share|improve this answer
    
Thanks, I'll try that as soon as I get back from holidays, I try that. –  tdi Aug 18 '11 at 11:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.