Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I generally watch lot of lengthy videos on YouTube. I always experience a problem because the screensaver is activated every 5 minutes.

I would like to know how to disable the screensaver while watching flash videos. I know, that I can change the screensaver timer or completely disable the screensaver. But I don't want to do that. I just want to disable it while I am watching full screen videos on my browser.

Update: I am using google chrome.

share|improve this question
add comment

2 Answers

up vote 5 down vote accepted

You'll have to patch the flash-player to send the appropriate signals, like Totem does. Unfortunately, most people have to use Adobe Flash, which is proprietary software.

But did you know that Totem supports watching videos from Youtube? It does deactivate the screensaver when you're playing stuff. You find it in the dropdown list that normally says playlist in the right-panel of Totem. Hope that helps. :)

share|improve this answer
    
Mirro would be an option too. –  desgua Aug 16 '11 at 21:35
add comment

Use caffeine, there is absolutely no need to patch flash player, that is way too much work when you can just install caffeine. When you run caffeine it will be in your notification area, a little coffee cup, when you want to watch a video just click on the icon and go to 'disable screen saver'. I use this all the time when I watch videos on the net. When you are done you can just click on the icon again and go to 'enable screen saver'.

https://launchpad.net/~caffeine-developers/+archive/ppa

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.