Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My speakers use a digital input, but my headphones use an analog input. I have them both plugged in, and when I want to use the headphones I just turn off the speakers and switch on the headphones. I know that simultaneous output on digital and analog is supported by the hardware, because it worked fine in Windows XP. But on Ubuntu, I seem to only get one at a time, depending on which setting is selected in the combo box located at System -> Preferences -> Sound -> Hardware.

How can I get simultaneous analog and digital output without having to switch the profile every time? I'm on Ubuntu 11.04 and it's an HDA Intel chip.

enter image description here

share|improve this question

1 Answer 1

up vote 9 down vote accepted

We have the optional application paprefs Install paprefs that allows to install a virtual output device to pulseaudio. This enables simultaneous output to all attached sound cards/devices:

paprefs

The additionally created audio output device for simultaneous output may be selected in the "Output" tab from pulseaudio sound preferences menu:

enter image description here


From the command line we can also load the device for simultaneous output without having to run paprefs by

pacmd load-module module-combine-sink
# pacmd load-module module-combine # for PulseAudio < 1.0

Put this line (without pacmd) in your /etc/pulse/default.pa to load this device at startup.

share|improve this answer
1  
great , it worked ! –  wim Aug 17 '11 at 12:41
    
Do you know how to do this without installing this application? I'm guessing it should be only a single command line operation. –  l0b0 Dec 14 '11 at 9:53
1  
@l0b0: see edit for this. –  Takkat Dec 14 '11 at 21:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.