Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So I have a Logitech Webcam Pro 9000 under 10.04 and I am trying to get it to work with Motion.

Here is the lsbusb output:

Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 008: ID 046d:0809 Logitech, Inc. 
Bus 001 Device 005: ID 15a9:0004  
Bus 001 Device 004: ID 058f:6362 Alcor Micro Corp. Hi-Speed 21-in-1 Flash Card Reader/Writer (Internal/External)
Bus 001 Device 002: ID 1058:0910 Western Digital Technologies, Inc. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

When I run Motion as user "motion" it doesn't work and I keep getting a Failed to open video device /dev/video0 error. However, when I run it as root, there is no problem and everything works fine.

I have a laptop running the same setup for motion and everything seems to work fine e.g. all the permissions on the files and the device are the same.

Any thoughts?

share|improve this question
up vote 0 down vote accepted

Figured it out.

Looks like the motion user wasn't part of the video group.


$ id motion 
uid=1001(motion) gid=1001(motion) groups=1001(motion)

So I did a:

sudo usermod -a -G video motion

and it worked. This is how it looks now:

$ id motion
uid=1001(motion) gid=1001(motion) groups=1001(motion),44(video)

I also noted that the motion user has a user uid and not a system uid. I think this may be because I added the user manually after an update instead of using the default user created by installing Motion.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.