Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I spend my days hopping between VPN connections in Ubuntu 10.10 and this is becoming severely annoying. What happens is that every once in a while - typically several times a day - when I click on the networking icon in the top bar, the nm-applet's VPN Connections flyout menu is gone. (Said menu item is still there, it just doesn't have a submenu or do anything when clicked.) Every time I killall nm-applet and start it again, which usually brings the menu back.

Has anybody here experienced this and been able to fix it?

share|improve this question

6 Answers 6

up vote 4 down vote accepted

This started to happen to me when I added the Nautilus Elementary PPA to my repo list. The version of network-manager-gnome available in that PPA is newer then the Canonical version and has some bugs in it that apparently crash the applet (causing the VPN menu to dissapear). You can check to see where your version of network-manager-gnome is coming from by opening synaptic and searching for network-manager-gnome. As of today, the latest Canonical version is 0.8.4~git.20110318t152954.9c4c9a0-0ubuntu1 and the maintainer of the package should be the Ubuntu Core Developers.

If you notice that your version of network-manager-gnome is not coming from the Canonical, select network-manager-gnome in synaptic and then select 'force version' from the package menu. This will prompt you to select the version you want to force, select 0.8.4~git.20110318t152954.9c4c9a0-0ubuntu1.

share|improve this answer
    
Sorry for not getting around to have a look at this sooner - thank you so much! –  Gustav Carlson Aug 24 '11 at 7:14
1  
Unfortunately, I am running the canonical version and still have this issue in 13.04 of ubuntu (0.9.8.0-1ubuntu2). For me the only thing that "works" is the killall of the applet an restarting it (which is not a great solution). –  Tim Jul 27 '13 at 1:58

I have the same issue.

I have that package version (0.8.4~git.20110318t152954.9c4c9a0-0ubuntu1), running on 11.04. The behavior started after upgrade from 10.10.

I ended up making a script to restart nm-applet which brings back my VPN menu but sometimes I do get the DBUS errors which I just run the script again...

Script:

#! /bin/sh
killall nm-applet
nm-applet --sm-disable &

Typical Message:

** (nm-applet:4808): DEBUG: old state indicates that this was not a disconnect 0
share|improve this answer

Thanks tons!!! this worked: I created a bash command called vpn-applet.sh

#! /bin/sh
killall nm-applet
nm-applet --sm-disable &

Then I

chmod +x vpn-applet.sh   

ran it (as root?), and the menu problem was gone. Now I don't need to reboot! Thanks

Please, lets get this nasty problem fixed. It is really annoying.

share|improve this answer

I got it to show again temporarily by going to Network settings and toggle the VPN on/off. Then the VPN appears again in the menu.

share|improve this answer

Are you being affected by bug 965895? There is an update for this pending in 12.04. You can try it from proposed in advance of the update being released.

share|improve this answer

I've installed Ubuntu 12.10 and the bug is still there. The VPN list disapeares some times after suspend/wake up. I found the bug report here: https://bugs.launchpad.net/ubuntu/+source/network-manager-applet/+bug/985028 it marked as duplicated, but the other one is marked as fixed. So vote this one if you still have the issue.

Temporary solution is:

kill -1 `pidof nm-applet` && nm-applet &

Add it to the aliases (in your ~/.bash_aliases file) fore easy use.

alias vpn-reload="kill -1 `pidof nm-applet` && nm-applet &"
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.