Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I boot my computer and login the volume level is always way too loud. Unfortunately the only way to change it is a physical knob on my speaker.

As soon as I can change the volume using my keyboard the volume immediately drops. Say the volume is at 100%, as soon as I turn the dial on my keyboard a little bit it drops to a normal level like 40%

How do I get this to work in a clear way, like having it remember the audio level it was on at shutdown?

Here's my audio card model: 82801JI (ICH10 Family) HD Audio Controller An Intel card on a Asus motherboard

share|improve this question
    
what model is your computer? Can you give details of what your audio card is (lspci / lsusb)? –  fossfreedom Aug 15 '11 at 22:18
    
I've added the info. It's a pci device. –  skerit Aug 17 '11 at 9:45
    
I think this is a bug. Happens to me too after going from 11.04 to 11.10 and accepting unity as a DE. –  Sean Houlihane Oct 23 '11 at 15:39
    
I'm encountering this, too, and have since 11.04. On login, my volume is set to 100% and it blares. –  Colin Dean Nov 2 '11 at 1:28

4 Answers 4

One option is to set a startup command with a lower setting, dunno if it works for your problem but should:

Do this: (change number 60 to your need between 0-100)

amixer cset iface=MIXER,name="Master Playback Volume" 60 >/dev/null
share|improve this answer

gnome-alsamixer which was recently not working is now fixed. Version 0.9.7~cvs.20060916⋯ is the one you want

You can install it by opening a terminal and typing sudo apt-get install gnome-alsamixer, enter then enter your password if asked…

This output is from an 10.04 LTS 64bit installation

you@yourcomputer:~$ sudo apt-get install gnome-alsamixer
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libavahi-qt3-1 libdb4.6++ kdelibs4c2a liblualib50 libdb4.6 kdelibs-data liblua50 libuu0
Use 'apt-get autoremove' to remove them.
The following NEW packages will be installed:
  gnome-alsamixer
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 56.6kB of archives.
After this operation, 610kB of additional disk space will be used.
Get:1 http://mirrors.us.kernel.org/ubuntu/ maverick/universe gnome-alsamixer amd64 0.9.7~cvs.20060916.ds.1-2 [56.6kB]
Fetched 56.6kB in 0s (313kB/s)         
Selecting previously deselected package gnome-alsamixer.
(Reading database ... 273170 files and directories currently installed.)
Unpacking gnome-alsamixer (from .../gnome-alsamixer_0.9.7~cvs.20060916.ds.1-2_amd64.deb) ...
Processing triggers for gconf2 ...
Processing triggers for man-db ...
Processing triggers for menu ...
Processing triggers for python-gmenu ...
Rebuilding /usr/share/applications/desktop.en_US.utf8.cache...
Processing triggers for desktop-file-utils ...
Processing triggers for python-support ...
Setting up gnome-alsamixer (0.9.7~cvs.20060916.ds.1-2) ...
Processing triggers for menu ...

Depending on what distro version you have gnome-alsamixer will open different ways.

But you can always open it in a terminal by typing gnome-alsamixer

me@mycomputer:~$ gnome-alsamixer

** (gnome-alsamixer:14935): WARNING **: gam_toggle_get_state (). No idea what to do for mixer element "Input Source"!

** (gnome-alsamixer:14935): WARNING **: gam_toggle_get_state (). No idea what to do for mixer element "Input Source"!

Ignore the terminal warnings, if any, it's the Window you want, an it should open (from my computer)… Gnome ALSA mixer window

Make sure the sound card (or possibly card chip name) is selected in the tab if there is more than one.

Then set the master volume to what you's like, and close.

If this doesn't fix the problem there a a coupla things to try:

  • open in terminal as above with gksu gnome-alsamixer instead of gnome-alsamixer and do the same. This opens the mixer as super-user.
  • open in terminal the non-GUI alsamixer and do the same thing. The non-gui alsamixer how-to is shown at Desktop install with Audigy Soundcard - no sound & errors in syslog which is how I fixed my system before gnome-alsamixer was working.

Good luck!

share|improve this answer

Set the sound settings the way you would like to have them when you boot. Then, run the following command.

sudo alsactl store

Next time you boot, the sound settings will be restored.

share|improve this answer

Could you perhaps have a look via a terminal at the results of this:

sudo alsamixer

and then check your levels on the graphs for your speaker or PCM...if they are in the red then use your up/down arrows to reduce them. This I hope will sort your audio problems.

There is also a fix for turning off the log in sounds for Ubuntu 11.10 as currently you no longer have the option to turn it off (for some reason)

Go back into your terminal and type

sudo gedit /usr/share/gnome/autostart/libcanberra-login-sound.desktop

Up will pop the text file for the libcanberra-login-sound

This edits the login sound and here you can

Search for NoDisplay

and enter it as

NoDisplay=false

Save and exit

Then up in the right hand corner of your desktop hit the Power Button and select Startup Applications. Here now you will see the the gnome login sound is now visible and so you can click/uncheck for it to be turned off spoiling hours of loud login sounds for the future :)

Hope that helps. Let me know if not

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.