Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In order to get webgl working on ubuntu I had to change some setting which somehow forced hardware acceleration to be turned on for a window. Unfortunately now all opengl viewports are always on top like an overlay and causes other annoying "overlay" glitches.

In any case I'm afraid I really can't remember what I did to break things and I don't know where I found that reference! Does anyone happen to have any ideas how I broke it or could fix it again?

I'm running the fglrx driver with ATI HD 5000 series card, Ubuntu 11.04. I'm also running ubuntu with the plain no effects classic gui.

Some glxinfo:

name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: ATI
server glx version string: 1.4
share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

It is a known issue with FGLRX and Ubuntu. I thought it only happened with Unity-2D but according to what you're saying it also happens with classic desktop. All OpenGL windows suffer from this problem. Take a look in here: https://bugs.launchpad.net/ubuntu/+source/unity-2d/+bug/800599 To disable webgl in Firefox you can type about:config in the address bar and search for webgl.

share|improve this answer
    
Thanks a lot, I thought that it was due to some strange setting but what you say makes sense. Maybe I'll switch back to Unity-3D (although I don't like it very much) –  Rehno Lindeque Sep 30 '11 at 11:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.