Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My computer for some reason is no longer booting into the GUI. It sends me straight to the command line. How do I get it to launch the GUI and how do I get it to launch the GUI by default on startup? I'm using Lucid Lynx.

share|improve this question
    
What happened before your GUI stopped coming up on boot? –  RolandiXor Aug 15 '11 at 16:54
    
@Roland Taylor, I'm not sure. My computer crashed, then when it came back up, it took me straight into the command prompt and has done that on every bootup since –  Kathryn Hallett Aug 15 '11 at 17:07
1  
Assuming it has a network connection, please run sudo apt-get install pastebinit && pastebinit /var/log/Xorg.0.log and edit your question to include the URL that that gives you (it is case sensitive) –  Oli Aug 15 '11 at 17:14
1  
@KathrynHallett: What graphics chip/card do you have? Btw, if you can log in to the system from the command line, try running sudo start gdm. –  RolandiXor Aug 15 '11 at 17:22
    
Doesn't look like I have a network connection, and the other two solutions by @Roland and wismonkey don't work. I would love to know why this stopped working, but since it's a brand new Ubuntu install, I think it would be easier to reinstall Ubuntu. Thanks anyway! –  Kathryn Hallett Aug 15 '11 at 20:25

2 Answers 2

This may not serve as an answer (but I can't comment yet): when u login on terminal type startx and see if that starts GUI for you or as Roland said try sudo start gdm Once your GUI starts you can provide more details easily as Oli is expecting to fix starting directly in GUI. If none of those work then you may have to work on terminal and provide more details.

Best luck :)

share|improve this answer
    
Roland is my name :), not Ronal :D –  RolandiXor Aug 15 '11 at 20:31
    
oops sorry just fixed it :) –  wisemonkey Aug 15 '11 at 20:39
    
thanks :D! Means a lot ;) –  RolandiXor Aug 15 '11 at 20:40
    
I had to use "sudo startx" since I wasn't logging in as root. I am using an NVidia GeForce GTX 460. Hopefully the proprietary drivers will help. I'll try that and report back. –  Alain O'Dea Sep 9 '12 at 3:10

I was able to get the login screen by running: sudo start lightdm

This was in Ubuntu 12.04.1 though so YMMV.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.