Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an Acer Aspire 5930

There are two buttons, which I can't use now: $ and

enter image description here
When I press those buttons nothing happens.
How can I use it?

On Windows I can use the program Launch Manager for it (from acer.com)

I tried System->Preferences->Keyboard->Layots->Keyboard model ->Acer->Acer Laptop But that didn't help me

share|improve this question
1  
Is your local set correctly? I.E. does it recognise your country and language? Look at System menu -> Administration -> Language Support –  arochester Aug 15 '11 at 16:22
    
@arochester. It was English lang first, now I add русский(eng. Russian, its my language), it not helps, on "Regionalformats" tab My country and language are ok –  RiaD Aug 15 '11 at 16:42

2 Answers 2

up vote 4 down vote accepted

This works with my Acer Aspire 8930g laptop:

Firstly, put in /etc/init.d/local, or whatever startup script your distro uses to run startup commands as root: Code:

    # dmesg | grep atkbd
  setkeycodes e033 219    # euro sign
  setkeycodes e034 239    # dollar sign

Secondly, execute these commands in your window manager startup (exactly how to do this, differs with every window manager, just to confuse us): Code:

    xmodmap -e "keycode 244 = dollar"
    xmodmap -e "keycode 195 = EuroSign"

In my experimentations, xmodmap can be run "too soon", which prevents it from taking effect! Try adding "sleep 5" before the xmodmap commands, if they don't seem to take effect.

Not sure if this makes a difference, but in xorg.conf I have: Code:

    Option "XkbModel" "acer_laptop"

Source: http://forums.fedoraforum.org/showthread.php?t=203271

share|improve this answer
    
Works with some others keycodes to xmodmap for me. acer_laptop is not important AFAIU –  RiaD Aug 16 '11 at 11:34

I have a 4 key that has both $ and € as meta keys.

  • Shift + 4 returns $
  • Alt Gr + 4 returns €
share|improve this answer
2  
I can use shift+4(but not altgr+4) too, But I don't want to have unused keys, if I can use it:) –  RiaD Aug 15 '11 at 16:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.