Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Compiz bails when I try to run it:

Xlib:  extension "GLX" missing on display ":0.0".
Compiz (opengl) - Fatal: Root visual is not a GL visual
Compiz (bailer) - Info: Ensuring a shell for your session

I have no idea why. It was working without a hitch, and one day, I realized compiz wasn't running. I tried to run it and the above message is what I got in reply. I looked under the menu, and saw some Nvidia program, so I ran it and it told me I wasn't using the nvidia driver and to run sudo nvidia-xconfig.

I ran it and it created /etc/X11/xorg.conf that wasn't there before. Upon restarting X, it complained that "nvidia" did not exist. [the driver] So, I've asked on ubuntuforums, and got no replies.

I figured I'd try here before I reinstall Ubuntu again. [Just upgraded from 10.10 to 11.04 a little while ago--it was working fine on both versions, it just started to quit working on 11.04 recently]

Edit:

matt: ~ $ lspci |grep VGA
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 0c)

In Additional Drivers, there is only 1: my WiFi driver, and it is activated.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

The graphics card you have in you question is an Intel - so it is a little strange why you would have something like nvidia-xconfig installed.

My suggestion would be to remove any traces of a previous nvidia install:

sudo apt-get purge nvidia*

Also - remove your xorg.conf file - i.e. you rarely need this with intel graphics

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

After rebooting - check that unity can run on your setup:

/usr/lib/nux/unity_support_test -p

It will confirm whether unity is supported - if in doubt add the reply to your question.

share|improve this answer
    
Ah. Thanks so much, this fixed it. I found out why it installed nvidia: I had installed pyopencl, which had nvidia-common as a dep... nvidia-common must have had some other deps, etc, so, yeah, got it removed, rebooted, and it's working now. Thanks again! Would upvote, but I don't have 15 rep yet.. –  Matt Aug 17 '11 at 18:06
    
And try this PPA: ppa:glasen/intel-driver (launchpad.net/~glasen/+archive/intel-driver). The latest intel graphics drivers updates are there. Just issue "sudo add-apt-repository ppa:glasen/intel-driver", then "sudo apt-get update" and "sudo apt-get dist-upgrade". –  Ivan Jun 5 '12 at 20:17

yes first remove all nvidia related drivers/softwares. And to get best performance and even 3d acceleration support from Intel card you need to have intel drivers from edgers ppa: https://launchpad.net/~xorg-edgers/+archive/ppa

sudo add-apt-repository ppa:xorg-edgers/ppa 

I've written about it few days back: http://hailubuntu.blogspot.com/2010/03/intel-graphics-card-and-3d-games-regnum.html

However while updating my ubuntu system with edgers ppa I had issues. You may need to look at https://help.ubuntu.com/community/CleanUpgrade

As far as 3d acceleration and all graphics bells and whistles are concerned edgers ppa would solve your issue.

All the best :)

share|improve this answer
    
This is not good advice - the edgers PPA (as the maintainers themselves state) is a very-very unstable PPA that could and often does break your graphics. You should use edgers with caution. Better advice would be to use the x-swat ppa BUT only if you have serious graphics issues that can't normally be worked around. launchpad.net/~ubuntu-x-swat/+archive/x-updates –  fossfreedom Aug 16 '11 at 18:44
    
I understand that using edgers is not really advisable, however I've exactly same Graphics (same laptop for that matter). And stock drivers for intel are no good if anything 3d (games are out of question) needs to be done. I've been using edgers for a while and for general use I didn't see anything broken. I didn't try x-swat yet though –  wisemonkey Aug 16 '11 at 19:52
    
I had 3d acceleration broken twice after update but that didn't render system unusable and were fixed right away. I'll look at x-swat as well, Thanks :) –  wisemonkey Aug 16 '11 at 19:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.