Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This problem seems centered around me, it has happened twice!

Description of the Problem

My Linux partition (ext4) got corrupted. I believe a bad superblock ...

So when I boot my computer I get no grub just a flashing monitor.

I fixed it using Windows 7 DVD.

Last Time this happened

I accidentally formatted my Ubuntu partition and so I reinstalled Ubuntu (10.04 32 - bit).

When this problem pops out

When grub updates I believe .. because the last time I got this error was when I updated grub.

This time also I was updating Ubuntu from 10.04 to 11.04 and grub got updated and the partition got corrupted!

Any idea how to get my Ubuntu partition back and what is causing this problem?


My entire ubuntu partition is corrupted !!!

share|improve this question

closed as too localized by James Feb 26 '12 at 2:01

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Can you try to make the question a bit clearer? I'm not exactly getting the point? – RolandiXor Aug 15 '11 at 13:54
@Roland Any idea how to get my Ubuntu partition back ? – HackToHell Aug 15 '11 at 15:06
You said the problem was with grub booting the system, not loosing your Ubuntu partition. Question is very unclear. – psusi Aug 15 '11 at 17:15
@psusi I edited it to make it more clear , I think that grub update corrupted my ubuntu partition ! – HackToHell Aug 16 '11 at 13:27
This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. :) – James Feb 26 '12 at 2:01
up vote 0 down vote accepted

not really sure what you mean by a "corrupted" partition, but as it seems to me, you simply lost your bootloader (grub)

to get it reinstalled please follow the answer in this post:

How do I restore grub after I ran a fixmbr command?

share|improve this answer
I do not know if that is the problem but I will try it out and post back ! – HackToHell Aug 17 '11 at 15:09

Not the answer you're looking for? Browse other questions tagged or ask your own question.