Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm failing with mounting XP share, receiving message:

...

mount error(110): Connection timed out

Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

When I try to list shares with smbclient, finally I receive message:

...

Running timed event "tevent_req_timedout" 0x7f2902964ad0

Error connecting to 192.168.34.140 (Success)

lang_tdb_init: /usr/share/samba/en_US:en.msg: No such file or

directory

Connection to 192.168.34.140 failed (Error NT_STATUS_UNSUCCESSFUL)

I wasn't able to find solution, could anyone advise?

Context:

  • I'm trying to mount share of NT-domain machine with XP which is accessed via VPN. While my ubuntu machine is still in default WORKGROUP. Is this possible at all?
  • Connection to target machine could be established, f.e. I can connect to it via RDP.
  • Command executed to mount: mount -t cifs //192.168.34.140/share_name /media/share_name -o username=XPDomainUsername,password=XPDomainPassword,workgroup=XPDomainName
  • Command executed to list shares: smbclient -L //192.168.34.140 -U XPDomainName\\XPDomainUsername --debuglevel=10
share|improve this question
    
What's the command you're running? –  jelmer Aug 14 '11 at 22:48
    
To mount: mount -t cifs //192.168.34.140/share_name /media/share_name -o username=XPDomainUsername,password=XPDomainPassword,workgroup=XPDomainName –  milkywayfarer Aug 14 '11 at 22:57
    
To list shares: smbclient -L //192.168.34.140 -U XPDomainName\\XPDomainUsername --debuglevel=10 –  milkywayfarer Aug 14 '11 at 22:59
    
It seems, that this is firewall issue, and file sharing ports are blocked for VPN connections. I can telnet on 445'th port of my XP machine from LAN, while I can't telnet the same via VPN, getting timeout exception: telnet: Unable to connect to remote host: Connection timed out –  milkywayfarer Aug 14 '11 at 23:14
    
I also had this problem, and specifying both hostname and IP solved it. –  user168673 Jun 20 '13 at 1:48

2 Answers 2

After a lot of searching I found a solution, which worked for me.

share|improve this answer
4  
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Octavian Damiean Feb 17 '12 at 15:36
    
Sometimes comments to answers are more valuable than the answer. –  migu Dec 11 '13 at 10:58

You might have to specify the IP address separately because most Windows servers require you to specify the NetBIOS name too, e.g.

smbclient -L XPHostName -I 192.168.34.140 -U XPDomainName\\XPDomainUsername --debuglevel=10
share|improve this answer
    
Thanks Jelmer. But unfortunately, filesharing via VPN is restricted in my network. –  milkywayfarer Aug 21 '11 at 15:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.