Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I couple of versions of Ubuntu ago I setup a program to start automatically when the computer turns on. It is of no use to me at this point, and I want to disable it now. The problem is, I can't figure out how I did it. I've looked in:

  • Startup Applications (gnome-session-properties)
  • ~/.config/autostart
  • ~/.config/gnome-session/saved-session/
  • /etc/init.d/
  • /etc/gdm/

Is there somewhere else I might have set it? Or is there a way to trace how a running program was started? Couldn't find anything like that in System Monitor.

share|improve this question
    
what is the application? –  Achu Aug 14 '11 at 21:01
    
@Achu: The program is an on-screen keyboard: onboard –  Jonah Aug 14 '11 at 21:07
    
Have you looked at gnome-session-properties ? –  desgua Aug 14 '11 at 21:24
    
@desgua: I don't think so, where is that? –  Jonah Aug 14 '11 at 21:25
    
You can access the gnome-session-properties by pressing alt+f2 and typing in gnome-session-properties –  Gus E Aug 14 '11 at 21:35
show 8 more comments

1 Answer 1

up vote 1 down vote accepted

Just grep it:

sudo grep -IRF onboard /etc 2> /dev/null

and if unsuccessful

grep -lIRF onboard ~/.[^.]* 2> /dev/null
share|improve this answer
    
The second one (sans the 2> /dev/null part, because I wanted to see where it was) turned up two results: ~/.gconf/apps/gnome-settings/gedit/%gconf.xml and ~/.gconf/desktop/gnome/applications/at/%gconf.xml. Removing the onboard bit fixed the problem. There's no way I would have known about those files: what program could have set those entries? –  Jonah Aug 14 '11 at 22:54
    
Isn't it one of those accessibility thingies? library.gnome.org/admin/gdm/stable/… –  arrange Aug 14 '11 at 23:13
    
I don't know. I just hope it's safe to remove the code, and it's not actually supposed to be left alone and is called by the actual setting... . In any case, I only commented it out, I didn't delete it. –  Jonah Aug 14 '11 at 23:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.