Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am able to view my share if I write the following

nautilus smb://privatenas

enter image description here

This open the shares on privatenas (C, home)

If I try the following

nautilus smb://privatenas/home

it opens a login window that asks for domain admin username and password.

Everything is fine, but what I am trying to do, is mount smb://privatenas/home to /home/administrator/PRIVATENAS

I have tried the regular mount command:

sudo mount -t smbfs //privatenas/home /home/administrator/privatenas -o uid=1000

But that gives me an error: asks for a password.

What am I missing?
What am I doing wrong?

Using the following

smbclient -L // -U administrator

That gives me a list of the smb shares. I want to mount one of them.

administrator@optitexfog:~$ smbclient -L //privatenas

Enter administrator's password:

Sharename       Type      Comment
---------       ----      -------
IPC$            IPC       IPC Service (PRIVATENAS)
c               Disk      Volume C
home            Disk      Private user folders
administrator   Disk      Private user folder

Server               Comment
---------            -------

Workgroup            Master
---------            -------

I thought I had it sorted, but I can't see my files.

OK, I have a feeling, that this is NOT a real windows share. The reason I suspect this is that if I browse to \\ I will NOT see the home folder.

OK, now, my last findings are sad. In order to test my theory, I created a test Share on my NAS. The mount command worked like a breeze. So, the //PRIVATENAS/home is NOT a real Windows share, or at least, not a share I can mount. This does not look correct to me. What should I check? As mentioned, I have a ReadyNAS, netgear 1100 with Raidiator 4.1.7

share|improve this question
up vote 2 down vote accepted

You are missing the username at your command. It should be something like this:

sudo mount -t smbfs -o username=saariko,uid=1000 //privatenas/home /home/administrator/privatenas  
share|improve this answer
Thanks, tried that. I get error : permission denied. I tried to use the admin user of the NAS (admin) not sure what username is needed. – Saariko Aug 15 '11 at 7:05
Check the configuration of your NAS. There should be a user and a password set for the samba access. – desgua Aug 15 '11 at 11:54
It's the same you have used with Nautilus. – desgua Aug 15 '11 at 11:55

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.