Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 11.04 on ThinkPad Edge 11" and no matter what X session or wm I use, P makes widgets blank out for a fraction of a second. After a quick search through gconf and XF86 symbol tables I can't find any place where it could be bound. I believe it may have something to do with low-level support for Win+P switching video outputs on Windows. Any suggestions?

share|improve this question
    
It is the exact same flicker as FN+F8 (switch video output). So I guess you are right with your hunch. –  queueoverflow Aug 13 '11 at 22:16

1 Answer 1

up vote 3 down vote accepted

If you are lazy just paste this on terminal:

gconftool-2 --type bool --set /apps/gnome_settings_daemon/plugins/xrandr/active False

The Super+P press is handled by gnome-settings-daemon.

Using gconf-editor, find the following conf key:

/apps/gnome_settings_daemon/plugins/xrandr/active

and set it to false (not checked). The change should be effective immediately after the edit.

enter image description here

References: 1, 2.

share|improve this answer
    
This doesn't seem to work anymore (14.04) but it could also be my environment –  Anders Eurenius Aug 14 at 8:37
    
this does work: askubuntu.com/questions/68463/… (possibly simply because it crashed the offending daemon, but it worked.) –  Anders Eurenius Aug 14 at 8:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.