Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Yesterday I bought a new PC. I've carefully chosen the parts, looking for compatibility. But, after I installed 11.04, things are really not working as expected.

My wireless card (RTL8185) is a pain to connect. I have to take the interface down & up everytime my PC boots. (but I'll work on that later).

And, the worst of all, Firefox crashes on almost every page load. I tried to debug it, and it says something related to I've spend the last 12 hours googling around with no solutions.

Downloading things from terminal (ie updates) works just fine.

Could some drivers (nvidia, or wifi) be messing with Firefox, causing it to crash? How can I fix this? I swear I already googled!

When I run it with GDB:

Starting program: /usr/lib/firefox-5.0/firefox-bin
[Thread debugging using libthread_db enabled]
Program received signal SIGSEGV, Segmentation fauld.
0xb6549942 in ?? from /usr/lib/i386-linux-gnu/

Full Stack Trace with gdb

I hope anyone can help me here!


UPDATE-1 Disabling Pango for Firefox with this line on .bashrc didn't work either.


UPDATE-2 After trying a lot of things, I've connected a LAN cable to my box and now everything works flawlessly. Too bad my router is far away from my desk. At least, now I know the problem is not Firefox, but my WiFi drivers. I'll post another question regarding my Wireless card Realtek RTL8185.

share|improve this question
There is two questions here - please ask two different questions. – fossfreedom Aug 13 '11 at 16:25
@fossfredom the question is: my firefox hangs, and it throws an error on, how can I fix it? The wifi issue, is just informative. Also, I have already tried without global menues, but it keeps crashing. – fedeisas Aug 13 '11 at 16:40
ok - start firefox from a terminal and copy and paste the output displayed into your question. – fossfreedom Aug 13 '11 at 16:42
Have you tried other browsers, I was just wondering if they do the same. Chromium is a good alternative to try. – Col Aug 13 '11 at 19:44
@Col yes, I've tried Chromium and it also crashes (although I haven't debugged the error). As a web developer, I'd prefer to use Firefox (many extensions come handy!). Any other suggestions? Thanks! – fedeisas Aug 13 '11 at 19:54

I see Pango and Font Config appear again and again.

Can you make sure that Pango is correctly installed and fontconfig is properly configured?

share|improve this answer
thanks for answering! I've tried disabling Pango onf Firefox (export MOZ_DISABLE_PANGO=1) but it keeps crashing. How can I make sure that Pango and fontconfig are properly installed and configured? Thanks! – fedeisas Aug 13 '11 at 19:10
@fedeisas: Searching for install instructions for them and simply following those, I'm not an Ubuntu user myself but just telling you what I'm seeing and think it could be. Good luck! Don't forget to add extra details and things you already tried to the bottom of your question so people get to read them... – Tom Wijsman Aug 13 '11 at 19:21

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.