Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Some days earlier I've noticed that almost every image I try to open, my Ubuntu system tries to open via 'iexplore'. I do not have wine installed, how this may happen?

enter image description here

I'm using Jupiter (elementary OS), it's based on Ubuntu 10.10.

share|improve this question
This screenshot seems to be taken from firefox. Does it happen only when trying to open a .png from a web page? – Pavlos G. Aug 13 '11 at 11:58
No, if i try to open from nautilus - it just doesn't open. (because it tries via iexplore too) – Evghenii Aug 13 '11 at 12:19
I guess Achu's answer solved the problem, right? – Pavlos G. Aug 13 '11 at 12:37
How to fix problem - is the second question (I could open image with 'open with other application' option). I don't undestand where it came from then? – Evghenii Aug 13 '11 at 20:17

1 Answer 1

up vote 2 down vote accepted

I don't know about Jupiter but if it's ubuntu based right click on one .png file go to Property -> Open with and check image viewer option. After that all .png files are will view on image viewer instead of iexplore.

open with

share|improve this answer
Yeap, thanks, I've changed. But I don't understand how IE turned up in my ubuntu? – Evghenii Aug 13 '11 at 12:21

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.