Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm new here, and I'm not very good at tech.... So help me here. The drivers I downloaded from Nvidia's website won't install, even after I boot into TERMINAL ONLY. After

sudo gdm stop

It doesn't do anything, but only says

could not recognize name; bailing out

or something like that. After I run the driver file, it says I need to remove XServer HELP PLEASE!

share|improve this question
up vote 3 down vote accepted

GT540M is an NVIDIA Optimus card. Those do not work by default. See also How well do laptops with Nvidia Optimus work?

Now, you shouldn't have installed the drivers from nVidia's website. If you're using a new installation, I recommend doing a clean install. Otherwise, jump into a terminal and run the below command to uninstall the nvidia driver:

sudo sh NVIDIA* --uninstall

(NVIDIA* is actually NVIDIA-Linux-x86*

To make use of your nvidia card, you could use Bumblebee. Within a few days, a new stable release should be available. Please do not install it from mj-casalogic/bumblebee PPA as it can break your system.

share|improve this answer
Sorry, but can you point me to a tutorial for Bumblebee? EDIT: Never mind, I've got it. Thanks! – Ben Yan Aug 12 '11 at 22:22
Please wait before installing, you might get issues like having the fans run at full speed or suspend/shutdown issues with the current "stable" version on ppa:mj-casalogic/bumblebee. Follow me ( or to get updates. We'll send a message to the linux-hybrid-graphics mailing list too when the release is stable enough and packaged well. – Lekensteyn Aug 13 '11 at 7:50

... Go to System Settings, and click on something like "Extra hardware drivers" or "Restricted drivers". It should automatically detect wich driver you need. Just choose it from the list, click the Activate button, and reboot your computer.

share|improve this answer
I've tried that, but it only crashes my card. – Ben Yan Aug 12 '11 at 22:20
Urk, that's strange :p – RobinJ Aug 12 '11 at 23:23

Sounds like you need to install the proprietary drivers provided by Nvidia for your card. If you are unsure how to do that here is a quick and easy tutorial I found Easy way to Install Proprietary Drivers in Ubuntu

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.