Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running 11.04, no remix. After installation, I could use wireless networks, but not ethernet. When I click on the connections menu item, it says

Wired Network
disconnected

How do I fix this?

Here is the ethernet portion of ifconfig:

eth0      Link encap:Ethernet  HWaddr 00:16:36:86:f3:43  
      UP BROADCAST MULTICAST  MTU:1500  Metric:1
      RX packets:0 errors:0 dropped:0 overruns:0 frame:0
      TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
      Interrupt:17

And the result of lspci:

00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 01)
00:1d.0 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
02:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5788 Gigabit Ethernet (rev 03)
02:09.0 CardBus bridge: Texas Instruments PCIxx12 Cardbus Controller
02:09.1 FireWire (IEEE 1394): Texas Instruments PCIxx12 OHCI Compliant IEEE 1394 Host Controller
02:09.4 Communication controller: Texas Instruments PCIxx12 GemCore based SmartCard controller
08:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Net

My /etc/network/interfaces looks like this:

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

And I get no output from sudo ifconfig eth0 up.

Output from nm-applet:

** (nm-applet:1824): DEBUG: old state indicates that this was not a disconnect 0
** (nm-applet:1824): DEBUG: old state indicates that this was not a disconnect 0

On second run of nm-applet:

** (nm-applet:2752): DEBUG: old state indicates that this was not a disconnect 0
** (nm-applet:2752): DEBUG: old state indicates that this was not a disconnect 0

** (nm-applet:2752): WARNING **: _nm_object_get_property: Error getting 'WpaFlags' for /org/freedesktop/NetworkManager/AccessPoint/10: (19) Method "Get" with signature "ss" on interface "org.freedesktop.DBus.Properties" doesn't exist



** (nm-applet:2752): WARNING **: _nm_object_get_property: Error getting 'RsnFlags' for /org/freedesktop/NetworkManager/AccessPoint/10: (19) Method "Get" with signature "ss" on interface "org.freedesktop.DBus.Properties" doesn't exist



** (nm-applet:2752): WARNING **: Error in getting active connection 'Vpn' property: (19) Method "Get" with signature "ss" on interface "org.freedesktop.DBus.Properties" doesn't exist


** (nm-applet:2752): WARNING **: _nm_object_array_demarshal: couldn't create object for /org/freedesktop/NetworkManager/ActiveConnection/0
** Message: <info>  No keyring secrets found for Auto HeyJude88/802-11-wireless-security; asking user.


** (nm-applet:2752): WARNING **: applet.c.2882 (applet_settings_new_secrets_requested_cb): couldn't find details for connection
** Message: <info>  No keyring secrets found for Auto HeyJude88/802-11-wireless-security; asking user.

** (nm-applet:2752): DEBUG: going for offline with icon: notification-network-wireless-disconnected
** (nm-applet:2752): DEBUG: foo_client_state_changed_cb
** (nm-applet:2752): DEBUG: foo_client_state_changed_cb
** (nm-applet:2752): DEBUG: foo_client_state_changed_cb
** (nm-applet:2752): DEBUG: going for offline with icon: notification-network-wireless-disconnected
** (nm-applet:2752): DEBUG: foo_client_state_changed_cb

Here's more to ifconfig:

wlan0     Link encap:Ethernet  HWaddr 00:18:de:31:70:20  
          inet addr:172.16.6.210  Bcast:172.16.6.255  Mask:255.255.255.0
          inet6 addr: fe80::218:deff:fe31:7020/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2384 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1367 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:514654 (514.6 KB)  TX bytes:215138 (215.1 KB)
share|improve this question
    
Can you run this command killall -9 nm-applet followed by nohup nm-applet & this should create a file called nohup.out in your home folder can you add the contents if any to your question –  Allan Aug 12 '11 at 18:17
    
Is nm network manager? What will this be doing? –  tekknolagi Aug 12 '11 at 18:20
    
see my edit for details –  tekknolagi Aug 12 '11 at 18:23
    
the commands will stop and restart network manager applet when you do this it will search for available connections and output messages to the nohup.out file. –  Allan Aug 12 '11 at 18:24
    
Just posted the output. That's all there is. 1824 is the pid. –  tekknolagi Aug 12 '11 at 18:26
show 2 more comments

3 Answers

up vote 1 down vote accepted

Edit the interfaces file to remove

auto eth0
iface eth0 inet dhcp

Save and restart. Use Network manager to edit the connection and set it to automatically connect.

This command will open the interfaces file in Gedit with permission to save the file:

sudo gedit /etc/network/interfaces

I have both a wired and a wireless connection and all that is in my interfaces file is these two lines

auto lo
iface lo inet loopback

I have found from experience than anything else will prevent a connection and removing what is extra will solve the problem.

share|improve this answer
    
I'm having the same problem as the original poster, but this didn't solve my problem. My interfaces file matches yours. The problem happens whenever I shutdown while connected to a wired network, then start back up without being connected to any network. I can't connect to WiFi hot-spots. –  user39051 Dec 23 '11 at 16:59
add comment

If you perform the same first command I mentioned in my comment

killall -9 nm-applet

Then

sudo service network-manager stop

which will stop the network manager service then enter this command

sudo rm /var/lib/NetworkManager/NetworkManager.state

Which will remove the NetworkManager.state file don't worry this file will be regenerated the restart the network manager service with this command

sudo service network-manager stop

and finally restart nm-applet with this command

nohup nm-applet &

It should hopefull be able to connect now.

The reason this happens is that the last time the network was disconected was because of a crash. Because the crash may be related to the network connection it is temporarily disabled to allow you to boot back in and fix the problem before re-enabling the connection.

share|improve this answer
    
I still get Wired Networks \n disconnected in the menu tray –  tekknolagi Aug 12 '11 at 18:35
    
added some more output from ifconfig, hope it's useful –  tekknolagi Aug 12 '11 at 18:38
    
This works for me, but the problem reappears whenever I shutdown while connected to a wireless network, then start back up without being connected to a network. I'm not able to connect to any Wi-Fi hot-spots until I perform these steps. –  user39051 Dec 23 '11 at 17:01
add comment
  1. Basic layer 1 ground check - is your ethernet port connected and are you sure the wire and modem port are fine? Please confirm that the ethernet port light blinks (either green or amber) when you connect the wire. Otherwise it is a physical layer issue. Does it work on other machines at the same swtich-port?

  2. Assuming the above is taken care of, Have you tried sudo ifconfig eth0 up?

  3. Also, check your /etc/network/interfaces file and see if the following line is there

    auto eth0

    This automatically enables eth0 on startup

share|improve this answer
    
see my edit for details –  tekknolagi Aug 12 '11 at 18:19
    
Right click on the network manager icon and see if "Enable networking" icon is enabled –  Sudipta Chatterjee Aug 12 '11 at 21:21
    
Enabled... Wireless works. –  tekknolagi Aug 12 '11 at 21:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.