Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have just had a major issue with my Ubuntu 11.04 Natty which I think is going to end up in a reinstall :-(

This is problem one of two so I've put them as two questions.

For some unknown reason I had a Distribution update on my Laptop yesterday which for all intend and purposes did nothing. No major version changes except in Evolution and LibreOffice plus some of the GNOME environment (my other question).

Now, whenever I boot my machine I receive this message

could not mount /dev/mapper/cryptswap1 M for manual S for skip

What would have caused this error and what on earth is Cryptswap1?

# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda1 during installation
UUID=c3cff8dd-1bf2-4618-8801-761b335c8d38 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
#UUID=fe10641d-a928-479e-ab3a-b0706b97b601 none            swap    sw              0       0
/dev/mapper/cryptswap1 none swap sw 0 0

sudo blkid | grep swap
/dev/mapper/cryptswap1: TYPE:"swap"

Crypttab
# <target name> <source device> <key file> <options>

ls -l /dev/mapper
total 0
crw------- 1 root root 10, 236 2011-08-16 05:28 control

Filename Type Size Used Priority
/dev/sda5 partition 1038332 86760 -1

share|improve this question
    
/dev/mapper/cryptswap1 is your encrypted swap, see askubuntu.com/questions/53242/check-if-partition-is-encrypted/… –  N.N. Aug 12 '11 at 15:57
    
According to that post my drive is NOT encypted so why is it trying to mount a some-what virtual drive? –  Christopher Stansbury Aug 12 '11 at 16:14
    
Please include the output of /etc/fstab in your question. –  N.N. Aug 12 '11 at 16:28
1  
Is there no comments (lines starting with #) in your /etc/fstab? If there is, it's important to include them here so we can se what's commented out and what's not. We need the exact contents of /etc/fstab. –  N.N. Aug 12 '11 at 17:01
3  
I've got a similar setup to yours and I get the message too. I'm also looking for a solution. –  N.N. Aug 13 '11 at 13:48

2 Answers 2

up vote 8 down vote accepted

In your /etc/fstab file, the /dev/mapper/cryptswap1 entry is there, which is why Ubuntu tries to mount it on boot. If you don't use encrypted partitions, that line shouldn't be there. For some reason the line created by the Ubuntu installer got commented out too. So just change (in /etc/fstab):

# swap was on /dev/sda5 during installation
#UUID=fe10641d-a928-479e-ab3a-b0706b97b601 none            swap    sw              0       0
/dev/mapper/cryptswap1 none swap sw 0 0

to

# swap was on /dev/sda5 during installation
UUID=fe10641d-a928-479e-ab3a-b0706b97b601 none            swap    sw              0       0

IMPORTANT: Before you restart, make sure you check that fe10641d-a928-479e-ab3a-b0706b97b601 is actually /dev/sda5 by running:

ls -l /dev/disk/by-uuid/fe10641d-a928-479e-ab3a-b0706b97b601

It should say something like:

lrwxrwxrwx 1 root root 10 2011-08-16 08:28 /dev/disk/by-uuid/fe10641d-a928-479e-ab3a-b0706b97b601 -> ../../sda5

The sda5 part at the end is the important part. Once you are sure the UUID matches the partition number, run sudo fdisk -l /dev/sda and make sure that /dev/sda5 is a swap partition.

Then just restart and that's it :) Hope this helps.

share|improve this answer
1  
A question about the IMPORTANT part. What should I do when the ls command doesn't have that output, but instead says: cannot access: No such file or directory? –  bozdoz Feb 27 at 21:24

Like Chen Xiao-Long discribed in his answer, you have to remove "cryptswap" line in /etc/fstab. Then you uncomment previously commented swap line so end of file looks like that:

# swap was on /dev/sda5 during installation
UUID=fe10641d-a928-479e-ab3a-b0706b97b601 none            swap    sw              0       0

To verify UUID and filesystem type (with cleaned cache), run:

~$ sudo blkid /dev/sda5 -c /dev/null

To try your new configuration immediately you have to reload /etc/fstab:

~$ sudo mount -a

Apart from that I have no idea why an (release?) upgrade causes this error.


Old version:

Request:

  • /etc/crypttab

  • ls -l /dev/mapper

  • lvscan (only LVM)

  • fdisk -l

  • cat /proc/swaps

  • why is your UUID line of swap partition commented?

  • is UUID output of blkid command same as in /etc/fstab (or is that all output of blkid)?

Temporay fix:

To suppress this message on boot you can add mount option "nobootwait" or comment line in /etc/fstab.

share|improve this answer
    
UUID from Fstab is 100% as is. The comment is, i believe in relation to the comment above stating that my crypt was on SDA5 during installation. I questioned this as well considering the installation has not changed and I only have one drive split into 2 partitions via the installation. The second line of my coding is the blkid which, as you can see shows no UUID. –  Christopher Stansbury Aug 16 '11 at 21:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.