Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can install the latest version of rabbitmq-server just fine using

sudo apt-get install rabbitmq-server

It installs version 2.3.1-1

I tried to install older versions by downloading the .deb file then installing the package

sudo dpkg -i rabbitmq-server_olderversion-1_all.deb

But I always get this error:

Not creating home directory `/var/lib/rabbitmq'.
Starting rabbitmq-server: TIMEOUT - check /var/log/rabbitmq/startup_{log,err}
rabbitmq-server.
invoke-rc.d: initscript rabbitmq-server, action "start" failed.
dpkg: error processing rabbitmq-server (--install):
subprocess installed post-installation script returned error exit status 1
Processing triggers for man-db ...
Errors were encountered while processing:

How can I install an older version?

share|improve this question

1 Answer 1

up vote 3 down vote accepted

You probably have some data from the newer version which may conflict with what the older version expects. It is unlikely that the older version knows how to downgrade the data fromats/configs etc from the new layout.

I had a similar problem when upgrading from some older version to 2.4.0 - on startup rabbitmq tried to upgrade its database but failed. Try uninstalling your current rabbitmq version, manually removing/renaming /var/lib/rabbitmq and then installing it again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.