Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently bought a Toshiba NB255-N245 and installed 11.04 with Wubi. It's working great, except that the Fn+F8 key, which should toggle the wifi on and off, does not have any effect in Ubuntu. It works fine in Windows 7. I'd like to be able to switch off sometimes to save battery, etc. Any ideas how to make it work? I tried rfkill block, but the wifi light on the indicator panel stays on. Or if it's been turned off on the Windows side, rfkill unblock won't turn it on.

EDIT:

As I said in a comment, sudo ifconfig wlan0 down brings the wifi down temporarily, but then it comes back up after a few seconds.

I booted up again after having disabled wifi via Fn+F8 on the Windows side. Ubuntu boots up with the indicator light off. I tried rfkill unblock wifi and rfkill unblock all with no effect or message. ifconfig -a does show wlan0, but sudo ifconfig wlan0 up gives an error message:

SIOCSIFFLAGS: Operation not possible due to RF-kill

This machine has an Atheros chipset, BTW. lspci reports:

07:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

I noticed that the network panel applet reports "wireless is disabled by hardware switch".

EDIT 2:

I found a bug report for this: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/764524

share|improve this question
    
you can force the interface to go down using ifconfig and sudo. Can you do me a favor and attach the output of ifconfig -a to your question? –  Thomas W. Aug 11 '11 at 16:00
    
@The Evil Phoenix: Unfortunately, I'm using it in Windows right now for work. I'll see if I can boot over to Ubuntu in an hour or so. –  Fred Larson Aug 11 '11 at 16:04
    
Okay, when we have the output i can post an answer saying "You can force the interface to go down using this command: <blah>" which will include the specific command to use for your setup. –  Thomas W. Aug 11 '11 at 16:06
    
@The Evil Phoenix: I think the interface is wlan0, if that's what you're getting at. I can't remember if I tried that, but I suspect that won't do any more than rfkill did. –  Fred Larson Aug 11 '11 at 16:13
    
it'll actually force down the interface, its worked on systems where the wifi switch doesn't work (on systems I own). try sudo ifconfig wlan0 down and see what happens –  Thomas W. Aug 11 '11 at 16:33
show 2 more comments

1 Answer

I have had this issue before and what worked for me was using a live cd of fedora and booting and then in terminal do rfkill unblock all. if it says hardware block press the fn f8 combination. then do the rfkill unblock all command again. i am pretty sure the problem has to do more with bios and mbr.

if that does not work in ubuntu do:

sudo rmmod ath9k sudo modprobe ath9k sudo ifconfig wlan0 down sudo ifconfig wlan0 up sudo dhclient

not working? let me know. i have the same card as you and have had the exact same problems.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.