Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Everything was working fine this morning. In the afternoon, I tried to boot into Ubuntu Lucid Lynx once again and I see no display. I hear the sound prompts of the login screen, so I press enter and type in my password, and I hear the sound of the Ubuntu Desktop. Which means that everything is working fine except that it does not display anything on my screen.

What can be a solution to this?

UPDATE: It Fixed itself, somehow. I still dont have a clue what the problem was so I will provide the details:

When I see the GNU grub menu, I see the following options

Ubuntu, with Linux - generic
Ubuntu, with Linux - generic (recovery mode)
Ubuntu, with Linux - generic
Ubuntu, with Linux - generic(recovery mode)

I normally use the first option to login, but I would just see a message (I remember it had something like RAM not loaded, or detected) and then it will go into blank screen.

I tried logging with the second option (recovery mode) as it looked like what I needed, and it had the oldschool dos-style blue menu, where I checked the option 'load ubuntu normally' and I was taken to a CLI.

I tried pwd, and it was showing my home directory. I navigated to one of my directories and compiled and executed a C++ program and it seemed everything was working fine. So I manually restarted and checked the first booting option, and everything is fine.

What could be a possible diagnosis of the problem I faced so that I dont face it again?

share|improve this question
Is the monitor properly connected? – N.N. Aug 11 '11 at 16:09
@N.N It is a laptop. – yayu Aug 11 '11 at 16:17
it the blacklight on? did you see the machine POST? What happens when you press alt+ctrl+F2 – user606723 Aug 11 '11 at 16:26
Dos it show the boot screen?. Can you see a virtual console (pressing CTRL+ALT+F1)?. Can you see the BIOS messages?. – Javier Rivera Aug 11 '11 at 16:31
@user The backlight was on. I did not see a splash screen, just a few command line like messages after grub. – yayu Aug 11 '11 at 16:34
up vote 1 down vote accepted

Without knowing what the exact error message was it will be difficult to diagnose. The basic sequence of events is :

  1. You failed to boot into ubuntu
  2. You tried recovery mode
  3. Recovery mode runs some extra checks on the system and repairs stuff when it can
  4. Whatver problem was fixed by the recovery mode basic tools
  5. You rebooted and it started normally

This could have been caused by anything from a bad shutdown to some intermittent hardware fault, so its hard to tell exactly what caused it to begin with.

Recovery mode does not automatically start X (the graphic display system) which is why you were dropped into a shell (This is done so you can repair a broken Xconfig from recovery mode). You can start X manually by typing startx as a command next time if you don't want to reboot. If you are running vanilla ubuntu that should start X and run your default display manager (Unity or Gnome).

share|improve this answer

The Ubuntu Wiki related to Troubleshooting BlankScreen provides useful information about why this problem occurs and how to fix it, which in my case solved my problem that was giving blank screen at the boot and I couldn't even see the Login Screen.

Related to what you refer about your issue, there is a part that reads just under "Non Symptoms":

If it occurs after entering your password on the login page, you have some different class of issue, such as an issue with 3D / DRM. Try disabling compiz (sudo chmod a-x /usr/bin/compiz), logging in as a different user, or turning off DRI.

However, I suggest you take a look at that document and check what of these can give you a clue on where to start for you to fix it.

Good luck!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.