Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How can I remove this shadow:

panel with shadow

from gnome-panel?

share|improve this question
2  
Please edit your question to tell us what desktop effects you have enabled and what theme you are using. –  dv3500ea Oct 10 '10 at 16:10

5 Answers 5

up vote 5 down vote accepted

You can do this with compizconfig-settings-manager Install CompizConfig, run it and go window decoration settings. Set window shadow to 'none'.

share|improve this answer
3  
This removes shadows from all windows, not just from the panel. –  Jonathon Oct 25 '10 at 11:04

If you want to keep shadows on windows but remove them from the panel,

Install compizconfig-settings-manager Install CompizConfig

you can use go to Window decoration

enter image description here

and set Shadow windows to (any) & !(type=Dock).

enter image description here

share|improve this answer
    
Do I need to logout and back in for this to take effect? Restarting compiz with "compiz --replace &" wasn't enough. –  popey Jul 9 '11 at 0:33
    
Ok, dunno what I'm doing wrong but I have followed this guide and it absolutely does not remove the drop shadow on the panel. –  popey Jul 9 '11 at 13:17
    
It doesn't work on Unity. –  Nyamiou The Galeanthrope Jul 23 '11 at 23:09
    
Just wanted to say this answer worked perfectly for me in gnome-classic. Or, as I like to call it, "gnome-proper". Thanks. –  Dave M G Jan 7 '12 at 4:00

you have to disable desktop effect from System>Preferences>Appearances and in the 'visual effects' tab select 'None'

though there might be some other way like in compizconfig-settings-manager without disabling desktop effect but that I dont know.

share|improve this answer
2  
This removes all desktop effects, not just the shadow on the panel. This means Expo, Cube, Blur, Fade etc. etc. will no longer be active. –  Jonathon Oct 25 '10 at 11:05

Just type or copy paste this: "any & !(type=dock)" under 'Shadow Windows' option in CCSM Window Decoration.

share|improve this answer

NOTE: This solution is for the Unity panel in Ubuntu 11.04+, while the question was asked for gnome-panel.

Replace /usr/share/unity/3/panel-shadow.png with an invisible image. In other words, edit that PNG file and make it 100% transparent and remove the black shade in the image. The panel shadow will then disappear after a logout/login.

You could also create a new PNG file with a width of 1 px (height could be anything, preferably 20px) in gimp Install gimp , and remove the background white layer. The entire PNG will then be transparent, and then you could put this PNG in /usr/share/unity/3/panel-shadow.png.

share|improve this answer
    
Feel free to ask the same question but tag it unity instead and then post this answer, that way we have a Q+A for both. –  Jorge Castro Jul 9 '11 at 15:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.