Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I've chosen a font by

System Settings -> Application Appearance -> Fonts

And there I've adjusted all fonts to be of 14th size. And also checked "Use my KDE fonts..." in Gtk+ appearance. I've also did the same using

kdesudo systemsettings

But still some fonts are tiny! It's not the 14th size!

enter image description here

Edit 2:

I thought it might be one of Gnome font settings. So I've increased all fonts in

gnome-tweak-tool
sudo gnome-tweak-tool
gconf-editor
sudo gconf-editor

No help!

Edit:

Ubuntu tweak also gives no help (note the tiny fonts!):

enter image description here

Edit:

It looks like the problem is with gtk3: when I compile emacs 24.0.92 with gtk3 - i get small menu fonts. When I do the same with a default gtk2 - everything is all right.

share|improve this question
1  
Is your screen's DPI correct? I found that when X assumed a 96 DPI on a screen that's 1366x768 and 11" (so, really 135 DPI!) fonts were far too small. If xrandr shows it's incorrectly detecting display size, you can forcibly change it to the correct size wiki.ubuntu.com/X/Config/… –  maco Nov 7 '11 at 18:43
    
It seems to be correct: 1600x900 59.9*+. The problem is still around. –  Adobe Nov 8 '11 at 7:06
    
@fossfreedom: Following Your advice I tried that - and have found that ubuntu-tweak doesn't change a signle font for me - nor does sudo ubuntu-tweak. –  Adobe Dec 9 '11 at 16:27
    
Please add to your question what version of Kubuntu you are using, how you installed it and if this is an upgrade. Please describe if you have installed any other desktop environments such as Unity, gnome-shell etc. –  fossfreedom Dec 9 '11 at 16:42
    
Deleted, sorry that Ubuntu Tweak didn't do the trick! –  William Dec 9 '11 at 17:17
show 1 more comment

2 Answers 2

Unfortunately this is a known bug in KDE, where the font size of the shutdown dialogue is not affected by system settings. Please vote for the bug on the bug tracker if you would like it fixed.

https://bugs.kde.org/show_bug.cgi?id=211501

share|improve this answer
    
I have small font here-and-there - not only at the shutdown dialog. I do believe it is because KDE can't link some Gnome config in the right way. –  Adobe Dec 12 '11 at 14:56
    
No, that is not correct. The reason for the small font in the shutdown dialog is because the size is hard-coded. grep for 'setPixelSize' in the code. Where else do you see incorrect fonts? –  scottl Dec 12 '11 at 18:24
    
Well - for example in the second screenshot in the question - the fonts are tiny. Where else? If I compile emacs with gtk3 - the menu fonts are tiny, in any dialog regarding root - despite I've configured all root settings to the 14th size of DejaVu Mono. –  Adobe Dec 15 '11 at 11:29
1  
@Adobe this bug has now been fixed bugs.kde.org/show_bug.cgi?id=216853 –  scottl Feb 8 '12 at 3:32
add comment
up vote 0 down vote accepted

The problem is resolved by installing

gtk3-engines-oxygen-git
gtk2-engines-oxygen-git

from here.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.