Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

We have a HP Photosmart B210 series printer.

The driver installed automatically without hassle (10.04 LTS Lucid Lynx) when I plugged the printer in and printing to A4 works like a charm.

However, this printer has a separate tray for photo paper (up to 13 x 18 cm) and while it is possible to choose Photo Tray as the paper source from the printer dialog, it displays A4 for the paper type and this cannot be changed. (Printing from the Gnome image viewer.)

Since this Laptop is primarily used by my parents, a one-click solution where they just have to select "print to photo" and have all tray/paper/border/quality settings automatically chosen would be ideal.


I've already updated to the 3.11 drivers from the PPA, but it's not really helping.

For example: I can select Photo-Tray+Best-Quality from the Gnome picture viewer, but in the printer dialog of the picture viewer, I cannot change the paper size from A4, so as soon as I try to print, I get an error telling me that the paper size doesn't match. (obviously, as the Photo Tray only supports up to 13x18cm)

Then I installed the GNOME photo printer, but this utility, while being able to print to the photo tray, doesn't allow me to select output quality and will print with the default A4 paper quality to photo paper ::-)


Ideas?

share|improve this question
    
Useful related question: askubuntu.com/questions/22896/how-do-i-print-photos –  Martin Aug 11 '11 at 8:03

2 Answers 2

up vote 0 down vote accepted

This is a workaround answer

This printer does have a SD/MMC card slot for directly printing from memory card.

The laptop I use here luckily also has such a slot, making things simple.

I just use an old -- 16 MB ;-) -- MMC card that came with one of my digital cameras to put a few photos on and the put this card into the printer, directly printing them without any setup required. Borderless. Best quality.

I think this will work very well for my parents. No settings to toggle. :-)

share|improve this answer

The version of the lucid hplip package which is used to provide your printer capabilities is quite old (3.10.2). Specific support for your printer was added in version 3.10.9.

I would try the latest hplip package from the hplip team PPA.


Related Questions:

share|improve this answer
    
Thanks. Certainly useful info. I've upgraded to 3.11 from the PPA, but the situation is unchanged. (I'll add a bit of info to the main question.) –  Martin Aug 16 '11 at 8:23
    
Marting - this sounds like a bug - possibly the same or similar to this one - my suggestion would be to file a bug report on launchpad with the detail shown in this bug report: bugs.launchpad.net/hplip/+bug/508152 –  fossfreedom Aug 16 '11 at 9:03
    
Yeah. It does seem like a bug. I should check the launchpad database when I find the time. –  Martin Aug 16 '11 at 9:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.