Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got a DELL Inspiron 6400 and i use Ubuntu 11.04, when I connect my TV screen via VGA it only works at a 1024x768. It worked fine in 10.10 at the full resolution 1360x768.

I've tried lots of steps but nothing worked, the resolution just won't change to 1360x768. If anybody can tell me what to do step by step i would appreciate. Sometimes it says it can't find the desire mode.

share|improve this question
1  
As you have mentioned, it doesn't find the mode you want, what have you tried?. –  Uri Herrera Aug 11 '11 at 3:53
    
iv tried adding new modes., but doest work... iv tried the xrandr commands to fix it and to add modes. etc etc –  Henry Horton Aug 11 '11 at 19:29

1 Answer 1

Issue xrandr on the console will show you the names of different outputs available on your system (LVDS, VGA-0, etc.) and resolutions available on each:

If you see the desired resolutions available for the output that you want (tv screen), set it via xrandr --output <output> --mode <mode> (example: xrandr --output LVDS --mode 1360x768)

If your desired resolution is not available, following the following example (example showing 800 600 but you should be able to do the same for 1360 768).

$ cvt 800 600
# 800x600 59.86 Hz (CVT 0.48M3) hsync: 37.35 kHz; pclk: 38.25 MHz
Modeline "800x600_60.00" 38.25 800 832 912 1024 600 603 607 624 -hsync +vsync

$ xrandr --newmode "800x600" 38.25 800 832 912 1024 600 603 607 624 -hsync +vsync
$ xrandr --addmode LVDS 800x600
$ xrandr --output LVDS --mode 800x600

Taken from Arch Linux Wiki.

share|improve this answer
    
This is an excellent diagnostic step. If you can get the correct resolution with xrandr, then it is definitely a software problem, not a hardware problem. –  djeikyb Aug 11 '11 at 4:04
    
i just get a full resolution before with the same tv a pc... can you send me the commands for my case couse im an amaeur at this things –  Henry Horton Aug 11 '11 at 19:32
    
i tried what you answered back but dindt work –  Henry Horton Aug 11 '11 at 20:08
    
it says that cannot find mode 1360x768 –  Henry Horton Aug 11 '11 at 20:16
    
Sorry, made a little bit to the xrandr --newmode , please try again. –  JohanSJA Aug 12 '11 at 6:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.