Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to install php5.3.6 on Lucid Lynx using oneiric repository to have everything in place on the ubuntu way and avoid manual package compiling.

I got the following error: Couldn't configure multiarch-support for libdb5.1, probably a dependency cycle.

The problem is libdb5.1 is depending on multiarch-support but multiarch support wants to install libdb5.1.

command used: sudo apt-get -t oneiric install php5 php5-common libapache2-mod-php5 When i try to install multiarch-support same way it says the same thing.

How should i solve this? The reaason for this is to change between versions of softwares on a clearer way without building custom deb packages from source.

Update 1

Yes, I am aware of this but i am just trying different scenarios because some of our development sites needed php5.2.x before that I installed from karmic repository on ubuntu lucid lynx and worked perfectly.

So I just wanted to test what if I want the most fresh version from oneiric repository. I hoped there is something than compiling it manually from source that I also tested and worked perfectly.

share|improve this question

closed as too localized by Jorge Castro, Marco Ceppi Dec 22 '11 at 17:13

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

The Oneiric repositories are not yet stable. You should not be upgrading from Lucid -> Oneiric directly, but rather upgrading to Natty first. Having said this, those repos for Oneiric are not stable, so you should not upgrade. – Thomas Ward Aug 10 '11 at 18:02

First I would not advise you to use a repository which is not meant for that series (maverick, lucid, oneiric etc). It can result in lot of problems and cryptic problems.

Do you specifically need the PHP version 5.3.6? Will 5.3.2 work? Being a minor version it should not be of much problem

If yes then you should do an apt-get update

sudo apt-get update

and then do an upgrade to install PHP 5.3 from the official repositories.

Since 10.04 is LTS, so it is supported even now.

The package php 5.3.2-1ubuntu4.9 was uploaded in Official repository on 2nd May 2011 by Steve Beattie.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.