Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed Ubuntu 11.04 on my new HP Pavillion g6 laptop. Unity was running from the liveCD. However, when I installed it, it wouldn't work. I logged in using Ubuntu Classic, and installed the proprietary graphics driver, hoping this would make it work, but it didn't.

Choosing "ubuntu" or "ubuntu classic" from the login screen yields to the same thing: gnome2 without unity.

How do I enable Unity?

share|improve this question

Ubuntu comes with an integrated video driver. When you use another driver for your computer it is recommended to remove the native drivers.

Make sure you have installed the driver of your video card. (If it is an NVidia card, you must have the Xserver installed too).

Then, you can remove the native driver of Ubuntu:

sudo apt-get --purge remove xserver-xorg-video-nouveau

This worked for me. Tell me if you have any problems.

share|improve this answer
No it didn't work :( It logs into classic gnome without even notifying me (it only did the first time). I'm thinking there might be something that should be edited with the conf files... p.s. I'm using ATI Radeon – Emad Aug 10 '11 at 8:12

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.