Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On system start, /var/run/dnsmasq/resolv.conf file ends up being blank. I had expected the resolvconf package to update it with the info from /etc/network/interfaces (dns-nameservers, dns-search).

I'm running a Ubuntu 10.04.2 LTS lucid server. I have both resolvconf and dnsmasq installed.

Here's the interfaces file section for eth0 (changed ip and dns names):

auto eth0
iface eth0 inet static
        address 10.100.1.100
        netmask 255.255.255.0
        network 10.100.1.0
        broadcast 10.100.1.255
        gateway 10.100.1.1
        dns-nameservers 10.100.2.2 10.100.3.2
        dns-search my-domain.com mydomain.com

If I run ifdown eth0 && ifup eth0 after start up, then the /var/run/dnsmasq/resolv.conf file is correctly populated.

share|improve this question

closed as too localized by fossfreedom Mar 4 '12 at 12:12

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Happens to me too with a nearly identical interfaces file on 11.04 (but without dnsmasq). I haven't found any good way to debug the issue. –  Beau Sep 19 '11 at 20:31
    
This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. :) –  fossfreedom Mar 4 '12 at 12:12
    
You hit bug #366967. The basic problem was that prior to Ubuntu 12.04, resolvconf, then a poorly maintained package in universe, had not been properly ported to the new Upstart environment. –  jdthood Oct 28 '12 at 19:58

Browse other questions tagged or ask your own question.