Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've a Samsung Galaxy mini with Android 2.2. Kies, the software provided by Samsung to manage my phone, doesn't run on linux,. I've tried to run it on wine, but it doesn't work at all.

Is there any way i can get this running on wine?

share|improve this question
add comment

3 Answers

up vote 4 down vote accepted

Yeah it's a major pain in the arse (speaking as somebody who has tried everything). Wine doesn't work reliably with things that need hardware connections. If you're trying to upgrade your phone's firmware, it's just plain not worth the risk.

VirtualBox (with Windows installed within, and the USB plugin installed) would normally be a viable option but for some reason VBox really hates my Galaxy S2. If you can get this to work, that's great.

For upgrading firmware I turned to Heimdall. This is essentially an open source replacement for Samsung's Odin tool (that isn't officially available to the public). I had success with this but I'm not sure it supports your phone.

Failing that, borrow a friends Windows laptop and install Keis. I tried this after VirtualBox failed but Samsung's 64bit drivers are awful. Plain wouldn't work. I think they've updated them since but it was too late for me. If you have easy access to a proper install of Windows you should probably try this first.

share|improve this answer
1  
Yeah, that's what i thought. Thnx anyway. I've windows in the other netbook, but i never use it... seriously, i don't need for most work i do. Linux only recognize the sd card if we plug in the phone, but no software at all and, eventhough Android is based in Linux, i don't know why Samsung doens't make Keis for linux... Anyway, i'll have to use windows to update firmware and i need to do it by the official way... contract terms. –  Jorge Pinho Aug 9 '11 at 20:37
1  
If you turn on USB debugging (in Settings → Applications → Development) you should be able to access the entire filesystem. –  Oli Aug 9 '11 at 20:52
add comment

I got Kies to work on my new Galaxy Note N7000 (still Gingerbread) with my Dell Dimension using Ubuntu 12.04 using Chromium, but only one way ie using the desktop as master and GN as slave, not the reverse. Deactivated data function on the mobile, connected the USB cable. The phone searched for linked devices and then displayed a network address, which I entered in the desktop browser address line. The browser loaded Kies which gave access to the mobile SD card for upload and download.

My destop is an older model and doesnt have wifi capability. seems to work OK although access.) It's not full desktop-mobile integration or syncing, but it's better than nothing and simpler than transferring single files with Bluetooth.

Wine refused to install the Kies executable on the desktop and complained that the package was faulty.

share|improve this answer
add comment

It works fine for my Galaxy S2 through Chrome. It did not work at all through Firefox, sadly. Install Chrome and you'll be fine!

share|improve this answer
1  
Do you know how kies works? What has it to do with chrome? –  Jorge Pinho Mar 5 '13 at 16:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.