Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 9.10 and my analog microphone does not work.

I tried to use ekiga, but my voice is not heard. I used the audio recorder and tryed to record my own voice, but nothing is recorded.

I started gnome-volume-control and disabled mute in the input part, and pushed the amplification to the maximum.

I started alsa info and pasted the output here: http://pastebin.com/ep6gBMre

I tried to use alsmixer in the gnome terminal, but I can't use it because the controls are distorted.

For any advice I would be grateful.

share|improve this question
    
How do you mean "I tried to use alsmixer in the gnome terminal, but I can't use it because the controls are distorted." In what way is it distorted? BTW there is a gui alsamixer gnome-alsamixer –  Allan Aug 9 '11 at 15:44
    
My gnome terminal is not displaying it properly. i.imgur.com/IMept.png –  Carsten Aug 10 '11 at 8:53
add comment

3 Answers 3

You don't say if you have properly configured your audio input, I suggest you take a look at Built-in microphone not detected? whose answer is placed here for your convenience:

Take a look at this:

Skype doesn't find my audio input

Original answer by @Treviño, Posted here for your convenience:

The only way I've found to make my internal mic work in my laptops is to use pavucontrol (install it from the homonymous package) and disabling the volume of a channel (the right or the left one), since most of microphones are mono in fact.

This is an huge workaround, by the way. I guess that this annoying bug should be fixed somewhere!

Pavucontrol - Input volume settings

It worked for me in several laptops with stereo and/or mono built in microphone (on screen or panel).

Additionally, you may wish to take a look at your sound preferences, mentioned in the same page. Click this link: Skype doesn't find my audio input (this will lead you to a different answer in the same page).

Also posted here for your convenience:

Under Sound Preferences, please post the "Hardware Tab" in order to check your profile, which should use at least an output + an input being in use. Otherwise, your hardware is not using the input profile which can be chosen right there.

This answer may be changed after your posting in order to give you further details. Here is a sample. Thank you.

enter image description here

Edit -- Here is the conversation in the general chat room.

Good luck!

share|improve this answer
    
I changed the Sound preferences in the hardware tab from analog stereo duplex to analog surround 4.0 Output + Analog Stereo Input. And tested it, unfortunately, the problem is still there. I read the conversation in the general chat room, if I understand it correctly, it basically is talking about the same thing. I will try pavucontrol next and gnome-alsamixer. –  Carsten Aug 10 '11 at 9:04
add comment
up vote 0 down vote accepted

Okay, I found the solution, but I had to overcome some hurdles, I will keep this here in case some else finds it.

  1. alsamixer did not work well in gnome-terminal, it didn't show all available buttons, and was more or less unusable. The solution for this problem was to call xterm from the gnome-terminal, and then start alsamixer in the xterm. xterm worked great for alsa mixer.

  2. Somehow, I experimented a lot in alsa mixer. I think that the final solution was to change the capture device from digital to analog microphone. In other words, I changed everything that said "digital" to analog. And somehow at one point, it just started working.

share|improve this answer
add comment

By using the following steps:

  1. Run alsamixer
  2. Unmute all the outputs by hitting M
  3. Hit Tab to go the capture settings
  4. Highlight the “Mic” setting using the arrow keys.
  5. Hit Spacebar to enable the microphone.
  6. Highlight the “Capture” setting using the arrow keys.
  7. Hit Spacebar to enable capture (note that just because you have volume bar here doesn’t mean it is enabled).
  8. Hit Esc.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.