Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I would like to install the restricted extras package, which I didn't select during the install. How can I do that?


is a meta-package that installs:

  • Support for MP3 and unencrypted DVD playback
  • Microsoft TrueType core fonts
  • Flash plugin
  • codecs for common audio and video files
share|improve this question
    
If you need DVD or Blueray playback there are some extra steps required. –  Stuart Aug 9 '11 at 13:20
    
1  
Google Chrome comes with built in flash player and plays all videos. Mozilla Firefox requires installing flash player Following link suggests to install Chrome :askubuntu.com/questions/79280/… –  Saurav Kumar Sep 2 '13 at 15:58
    
You need askubuntu.com/a/56448/2973 –  wojox Sep 2 '13 at 15:59

3 Answers 3

up vote 15 down vote accepted

First, be warned that it might not be legal in some countries, because of software patents.

With that being said, here is how to install it, click here:

ubuntu-restricted-extras Install ubuntu-restricted-extras

Or you can open up a terminal and run the following command:

sudo apt-get install ubuntu-restricted-extras

Select yes, and you'll have ubuntu-restricted-extras installed and working.

share|improve this answer

I suggest to install Ubuntu Restricted Extras through Ubuntu Software Center. It will install all media codecs plus java and flash plugins.

Well I think you need to enable multiverse on Software and Updates (if you use Ubuntu 12.04, you can access software properties or something like that from Ubuntu Software Center > Edit menu)

enable multiverse

Then close the Software Center and open Software Updater (Update Manager on 12.04) to update the package lists. Alternatively you can run sudo apt-get update from Terminal.

After update got completed, open Software Center again and look for Ubuntu restricted extras to install.

Ubuntu restricted extras

If you still can’t find the package, try sudo apt-get install ubuntu-restricted-extras from a Terminal and see if it results in an error.

share|improve this answer
    
I've found the software center but cannot find the icon for Ubuntu retstricted extras? –  vincent Sep 2 '13 at 16:14
    
@vincent There is no icon just for this it is just a box of tools that is the generic icon for system tools. you can find it by searching for it by name in the text box in the upper right of the Software Center. If you want to find theses ind of things without knowing their complete name you need to click the bottom left where it says "Show xx Technical Items" to show the hidden items that are usually this kind of software. –  TrailRider Sep 2 '13 at 16:23
    
@vincent, as TrailRider mentioned, Ubuntu restricted extras is not an app so there’s no icon for it in Dash or somewhere, you need to search for it inside Ubuntu Software Center. I just edited my answer to add screenshots and more information. I hope it will help. –  AliNa Sep 2 '13 at 16:37
    
@TrailRider thanks a lot, but I think it will be excellent if it can help the question owner. ;) –  AliNa Sep 2 '13 at 16:52

Just click this link to apt repository.

Or go to software centre and install Ubuntu-restricted-extras

Or use apt-get, type in terminal

sudo apt-get update && sudo apt-get install ubuntu-restricted-extras
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.