Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've tried both Rhythmbox and Banshee for syncing my iPod Touch 3g.

However it frustrates me that it took them so long to sync up all my songs (~1700). It took around 3~4hours.

Curious to see how long it took in Windows, I booted into my windows partition and tried to sync my iPod from scratch (using Mediamonkey, apparently iTunes can't import my playlist properly) again with the same amount of songs and to my surprise it only took ~30minutes, I tested by selecting a few songs to made sure it worked (Rhythmbox failed me once after I finished my sync, the file is there but not playable), and it did!

Has anyone encountered similar problem and has a solution? Thank you.

share|improve this question

closed as too localized by fossfreedom Mar 12 '13 at 22:02

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Could you describe what part takes so much time? E.g., with me in Banshee, the 'converting' takes ages. Thanks. –  Exeleration-G May 29 '12 at 21:15
    
I believe its the 'converting' part. It is the part where it says "Adding track # of #ofsongs. It would take around 5~10s to convert one audio mp3 file. Based on rough calculation it would take 166 minutes to transfer 2000 songs if every conversion is done in 5s –  haru Sep 19 '12 at 8:19
    
Try to reset your iPod Touch 3G to factory settings. After that, sync it with Banshee. It seems like Banshee can't sync properly if the iPod has been synchronised with iTunes first. –  Exeleration-G Sep 19 '12 at 11:11
    
I've just tested restoring my ipod, after which I used itunes solely for restoring my data (nothing involving music). Went back to banshee and its the same. [Side note] Under device properties it wrote 'Encode to: MP3 (LAME Encoder)' with 128kbps constant bitrate, its the only choice I have. –  haru Sep 19 '12 at 23:27
    
Mm. What happens when you restore the data afterwards? On SuperUser, someone has posted a workaround for the converting using gtkpod. You might want to take a look at it. superuser.com/questions/292647/… –  Exeleration-G Sep 20 '12 at 11:35

Browse other questions tagged or ask your own question.