Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have some play/pause, stop, next etc. keys on my Dell Vostro 1510. These interact with Banshee but don't with Amarok. How can I bind the latter to those keys?

share|improve this question
    
Banshee has a "multimedia keys" extension that is enabled by default to handle this sort of thing. I'm not sure what's available for Amarok, though. –  michaelms Aug 8 '11 at 18:03

2 Answers 2

up vote 8 down vote accepted

Amarok is set up to use the X keycode "Media play" as a global shortcut for play/pause. Sometimes, however, your keyboard configuration may not be properly recognized for whatever reason - in which case, you can specify it manually. To do this, follow the instructions below:

  • Open Amarok
  • Select "Settings" from the menu and choose the "Configure shortcuts" submenu.
  • Type "play" in the filter box, this will filter display all possible shortcuts that has the word "play" in it.

You will see a few items named something with "play", and one of them will be "Play/pause".

a busy cat

You will also see three columns: "Shortcut", "Alternate" and "Global". The two first are valid only when Amarok is in focus - that means whenever you are inside Amarok and fiddling around. The "Global" keyboard shortcut, however, will work regardless of whether Amarok is minimized, in the notification area or you have it open.

  • Press the little triangle in the "Global" column for the "play/pause" entry. This may already have the words "Media play" shown (this is the current shortcut for this action - if you have a proper media keyboard, the "play" button will usually trigger this action in Amarok).
  • With the entry now expanded, click the button after "Custom" that says "None". When you have clicked it, it is in "recording" mode, so press the key you want to be assigned to this function. When it is released, it should show up on the button you just clicked, next to the text "Custom". Make sure this also selects the radio box for "Custom" and then click "Apply".
share|improve this answer

I also had to switch off the shortcut below so that the amarok global shortcut works.

System Settings > Keyboard > Shortcuts > Sound and Media > Play / Pause
(it may differ a bit, I'm running a non-English system)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.