Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried to upgrade from 10.04 to 10.10 - now that Ubuntu 10.10 is finally released. I used update-manager -d and the first window after pressing the upgrade button says that it is still a development release.

Is this true? Or have they not changed this window yet?

share|improve this question
up vote 7 down vote accepted

update-manager -d is the command to upgrade to development trunk versions of Ubuntu.

However, I think I recall Ubuntu updates the repositories to notify about the new release a few days after the release is live so that when people are prompted to upgrade, the bandwidth use spike from the day 1 enthusiasts has been fully absorbed. By using that route, you should still end up with a copy of "blessed" Ubuntu 10.10.

That said, even if it was marked as a development version, it wouldn't be any different. Go ahead, make your day!

share|improve this answer
I tried to upgrade but I got a an error: 'E:Couldn't configure pre-depend x11-common for x11-xkb-utils, probably a dependency cycle.' Maybe is something I installed. – Florin Oct 10 '10 at 14:41
@Florin, if you'd like to ask a new question please do so. You'll find it is a duplicate of this question, which already has an upvoted answer. :) – badp Oct 10 '10 at 14:48

It will be changed in a few days.

share|improve this answer

You just have to run the update manager as normal from the System -> Admin menu as normal, and you'll get an option at the top of the windows to upgrade your distro.

share|improve this answer

When you type lsb_release -a in your terminal, you'll see that it says Ubuntu 10.10. Before there was also 'development brach' added.

share|improve this answer
You mean that you've done the upgrade with no problems and that in fact it upgraded to 10.10 final? – Florin Oct 10 '10 at 14:01
Note that it should be lsb_release -a. – Tommy Brunn Oct 10 '10 at 14:10

Your actually suppose to run

update-manager -c
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.