Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Compiz visual was working perfectly just days ago after a restart (no update nothing) it stopped working at startup, i have to run "compiz --replace" for it to work again and get recognized

I would like to have my compiz visual affects to work spontaneously on startup

Running ubuntu 11.04

thanks

share|improve this question
    
OK figure out a work around am not sure its the best way but it works I added to the startup application "compiz --replace" Working fine now If anyone have a better solution (if this is a bad one) please share –  bhappy Aug 7 '11 at 23:12

1 Answer 1

up vote 1 down vote accepted

Adding "compiz --replace" at Startup Applications is a perfectly fine workaround. I found that sometimes this problem is caused by some configuration file. See this bug report at launchpad.

In my case, the problem was caused by a file named "gnome-wm.desktop" at "~/.local/share/applications/" and was solved after deleting it. The content of this file was:

[Desktop Entry]
Exec=gnome-wm
Hidden=true
Name=Window Manager
NoDisplay=true
Type=Application
X-GNOME-Autostart-Notify=true
X-GNOME-Bugzilla-Bugzilla=GNOME
X-GNOME-Bugzilla-Component=general
X-GNOME-Bugzilla-Product=gnome-session
X-GNOME-Bugzilla-Version=2.32.0
X-GNOME-Provides=windowmanager
X-Ubuntu-Gettext-Domain=gnome-session-2.0
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.