Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just installed 64-bit Ubuntu 11.04 and after I updated it, the clock stopped displaying the right time. It's now 8 hours behind my normal time. I've checked the Time and Date settings and the Location field is correct. What's even weirder is that the time displayed in Time and Date Settings adjusts itself after a few seconds and is correct. The time displayed in the task bar remains the same, however.

Any ideas?

share|improve this question

4 Answers 4

You can use the GUI in the time and date preferences to set your timezone and then be sure to run this command in the terminal:

sudo ntpdate ntp.ubuntu.com

This will ensure that your machine polls the ubuntu server to get the right time and date for your timezone.

To verify, type

date    

in the terminal.

share|improve this answer
    
I tried the ntpdate command and I'm getting this: ntpdate[26581]: no server suitable for synchronization found –  friederbluemle Jan 3 at 2:01

First, ensure that you have the right time zone set. Open the app "Time and Date" and click the little Lock icon and input your password to unlock, at which point you can set your time zone.

Second, open a Terminal and input this command: sudo apt-get install ntp

Restart your computer and check the time by going to this website: time.is

share|improve this answer
    
I did all that and, even though time.is displays the correct time in my timezone, the time displayed on my computer is still 8 hours behind. –  LucianU Aug 8 '11 at 19:17

Today I stayed an hour longer at work because the KDE clock widget showed the wrong time. The evening guard had a great laugh! :) Time and Date setting themselves are OK, auto adjust set and set to NTP pool. On the command line date is OK as well...

Turns out it's in the widget settings itself:

  • Rightclick on clock widget and select 'Digital Clock Settings'
  • Choose 'Time Zone': both UTC and your local timezone (Amsterdam in my case) should be selected... but here's the crunch:
  • Below 'Clock default to' was set to UTC; changed this to my timezone and applied.

Voila!

share|improve this answer
up vote 2 down vote accepted

I've finally found the solution. I had to edit my ~/.profile and replace TZ='America/Chicago' with my own timezone. After making the change, logging out and logging back in, the time displayed is now correct.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.