Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I try to update my Ubuntu 10.04 installation to 10.10 I get the following error.

Could not calculate the upgrade

An unresolvable problem occurred while calculating the upgrade:
Trying to install blacklisted version 'blcr-dkms_0.8.2-13'

 This can be caused by:
 * Upgrading to a pre-release version of Ubuntu
 * Running the current pre-release version of Ubuntu
 * Unofficial software packages not provided by Ubuntu

If none of this applies, then please report this bug against the 'update-manager' package and include the files in /var/log/dist-upgrade/ in the bug report.

None of the three applies to me (I think).

Now I found that this also affects someone else:

Is there here someone who knows what could be wrong? Or a workaround so that I can install Maverick Meerkat?

share|improve this question
up vote 8 down vote accepted

Based on the good suggestion by PocketSam

Look with aptitude why blcr-dkms why the package is installed, and remove that package if possible. For me, this was the package r-cran-rmpi which I actually don't use but installed with a apt-get install r-cran-* command.

Don't forget to do a apt-get autoremove to really uninstall the blcr-dkms package automatically.

The reason for this package not working is explained here

share|improve this answer

Maybe you may try to remove this module using dkms?

sudo dkms uninstall blcr-dkms 
sudo dkms remove -all blcr-dkms

Have no idea if it will break something. BLCR (Berkeley Lab Checkpoint/Restart) allows programs running on Linux to be "checkpointed" (written entirely to a file), and then later "restarted".

share|improve this answer

I got the same message but when I tried for the third time using sudo update-manager -d It worked...

share|improve this answer
Third time it worked for me too!! – pramod Oct 10 '10 at 21:09
As @Toby Lunn, @Bert, @pramod, it worked for me after having tried a few times. – Agmenor Nov 20 '10 at 18:40

I was getting this bug, but it seems to be solved after I did a

sudo apt-get install blcr-dkms
share|improve this answer

Use Synaptic and simply uninstall the blcr-dkms package.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.