Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am having a problem where some programs, including Software Center, Update Manager, and Synaptic all close down immediately after opening. The window comes up, but disappears before i have a chance to do anything. People with similar problems have submitted bug reports with similar errors, but none seem to apply directly to my situation. When I run the Software Center from a terminal, I get the following script. I appreciate any help. Weston

[sudo] password for wes: 
2011-08-07 10:41:38,788 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/share/software-center/softwarecenter/db/database.py', 154, 'open')'
2011-08-07 10:41:38,788 - root - WARNING - failed to add sca db Couldn't stat '/root/.cache/software-center/software-center-agent.db' (No such file or directory)
/usr/share/software-center/softwarecenter/app.py:1192: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
  self.window_main.show_all()
2011-08-07 10:41:39,873 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/lib/pymodules/python2.7/zeitgeist/client.py', 367, 'reconnect_monitors')'
2011-08-07 10:41:39,872 - zeitgeist.client - INFO - Reconnected to Zeitgeist engine...
/usr/share/software-center/softwarecenter/SimpleGtkbuilderApp.py:50: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
  gtk.main()
2011-08-07 10:41:44,253 - softwarecenter.backend.scagent - WARNING - error in query_info 'Operation not supported'
2011-08-07 10:41:44,254 - softwarecenter.db.update - WARNING - error: Operation not supported
share|improve this question
add comment

2 Answers

From the error report it looks like you have, at some time, run sudo software-center and the root user has claimed the ownership of the software-center cache.

Try

sudo chown -R wes:wes ~/.cache/software-center

As to the others - it is worth launching synaptic and update-manager from the terminal to see if you get similar error.

Its perhaps work checking that you haven't accidentally changed the ownership of .cache and some/all subfolders to root.

i.e.

ls -ld .cache

and

ls -ld .cache/*

share|improve this answer
add comment

I have had the exact same issue as described in the question, but with Terminator (terminal emulator). The Terminator window opened and closed immediately after that. I checked all ownerships of the files and folders in the ~/.cache directory, but that was not the case. Re-installing the program also didn't help. The solution was to remove the configuration file at ~/.config/terminator/config and then tried to start terminator. Then worked as expected.

Edit: This was in Ubuntu 12.04.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.